Vraag Kan Skype niet installeren vanwege afhankelijkheidsfouten; dpkg installeert geen afhankelijkheden [gesloten]


Ik probeer de nieuwste Skype-versie (4.1) op mijn Linux te installeren.

Ik heb de skype-ubuntu-lucid_4.1.0.20-1_i386.deb pakket van de officiële Skype-site.

Ik heb alle geïnstalleerde versies inclusief de configuratiebestanden verwijderd.

Nu wanneer ik het gedownloade pakket probeer te installeren, krijg ik de volgende fouten:

Unpacking skype:i386 (from skype-debian_4.1.0.20-1_i386.deb) ...
dpkg: dependency problems prevent configuration of skype:i386:
 skype:i386 depends on libqt4-network (>= 4:4.8.0); however:
  Version of libqt4-network:i386 on system is 4:4.7.4-0ubuntu8.2.
 skype:i386 depends on libqtgui4 (>= 4:4.8.0); however:
  Version of libqtgui4:i386 on system is 4:4.7.4-0ubuntu8.2.
 skype:i386 depends on libqtwebkit4 (>= 2.1.0~2011week13); however:
dpkg: error processing skype:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
 skype:i386

Nu dacht ik: ik kan de ontbrekende afhankelijkheden handmatig installeren, maar als ik dit probeerde, kreeg ik weer afhankelijkheidsfouten. Het lijkt erop dat afhankelijkheden van een pakket niet automatisch worden gedownload en geïnstalleerd.

Is er een opdrachtoptie voor dpkg zodat missende afhankelijkheden automatisch worden geïnstalleerd?


8
2017-11-26 10:35


oorsprong


Welke versie van Ubuntu gebruikt u? - To Do
Ik heb geïnstalleerd "Linux Mint 12 Lisa", die is geüpgraded naar Mint 13. - MrPink
Ok Micha, maar "Linux Mint" is geen officiële Ubuntu-distributie ... maar ik denk dat, als je "Mint 13" gebruikt, het skype-pakket voor "exact" is en niet voor "Lucid" .Package voor (ubuntu 12.04 multicarch ). dan zou je het moeten installeren met gdebi. - Roman Raguet
Ok, ik heb dit ook geprobeerd maar krijg nog steeds: Unpacking skype:i386 (from skype-ubuntu-precise_4.1.0.20-1_i386.deb) ... dpkg: dependency problems prevent configuration of skype:i386: skype:i386 depends on libqt4-network (>= 4:4.8.0); however: Version of libqt4-network:i386 on system is 4:4.7.4-0ubuntu8.2. skype:i386 depends on libqtgui4 (>= 4:4.8.0); however: Version of libqtgui4:i386 on system is 4:4.7.4-0ubuntu8.2. skype:i386 depends on libqtwebkit4 (>= 2.2~2011week36); however: dpkg: error processing skype:i386 (--install): dependency problems - leaving unconfigured - MrPink
.. de skype-versie vanuit de pakketbeheerder kan zonder problemen worden geïnstalleerd, maar het is de versie 2. * wat ik niet wil. ; ( - MrPink


antwoorden:


Welnu, voor zover ik weet, kan dpkg de afhankelijkheden niet oplossen, maar omdat je dat wel hebt Ubuntu Lucid 10.04 geïnstalleerd, kunt u gebruiken "Gdebi" * (gui-tool en afhankelijkheden van afhankelijkheden) * gewoon doble klik in het .deb-pakket.

Een andere optie is ... je kunt rennen sudo dpkg -i package.deb  (het zal geen volledige installatie met foutenafhankelijkheden zijn).
  Daarna ren je gewoon weg sudo apt-get -f install en de apt-get tool zal de ontbrekende afhankelijkheden corrigeren.

Ik hoop dat dit nuttig zal zijn !.


12
2017-11-26 11:19



Oke ik zal het proberen gdebi. Het probleem met sudo apt-get -f install is, dat het herkent dat er een kapot pakket is (skype) maar in plaats van de ontbrekende afhankelijkheden te installeren wil het het kapotte pakket verwijderen. - MrPink
Ok Micha, je kunt een andere optie proberen en is sudo dpkg -i package.deb en ga dan naar de sypactic tool en in het menu en gebruik Bewerken> Herstel kapotte pakketten. - Roman Raguet
Ik heb het geprobeerd, maar het is hetzelfde als het uitvoeren sudo apt-get -f install de pakketbeheerder wil skype verwijderen in plaats van de nodige afhankelijkheden te installeren. - MrPink
Dit heeft het voor mij opgelost, bedankt. - Cerin


Als je gebruikt 64-bits Linux, dan is dit probleem meestal te wijten aan ontbrekende bibliotheken.
Ga naar Ubuntu Software Center en installeer ia32-libs pakket en installeer vervolgens Skype.Hope opnieuw. Hiermee wordt uw probleem opgelost.


1
2017-11-26 11:34



De softwaremanager zegt dat ia32-libs is al geïnstalleerd. - MrPink