Vraag Schijfversleuteling is mislukt en opnieuw installeren werkt niet


Ik neem hier de volledige schuld van, maar ik heb mijn systeem verpest en weet niet meer wat ik vervolgens moet doen. Dit is wat er is gebeurd en ik hoop dat iemand me advies kan geven over de volgende stappen.

  • Ik heb een Acer Aspire One, oorspronkelijk met Windows 8.
  • Ik heb 13.04 op een usb-schijf gezet en met succes geïnstalleerd. tijdens de installatie heb ik alle bestaande partities enz. verwijderd, volledig nuked windows 8 (yay!)
  • Ik heb volledige schijfversleuteling gebruikt (ik heb dit wachtwoord nog steeds)
  • Alles werkte goed, en DIT is waar ik een fout heb gemaakt
  • Ik besloot dat ik een andere distro wilde proberen, en terwijl ik het aan het downloaden was, besloot ik om dezelfde Ubuntu USB-stick te gebruiken om op te starten, vervolgens gparted te openen en de partities op de harde schijf te 'verwijderen'. Het downloaden van de andere distro die ik wilde proberen (OpenSUSE) duurde te lang, dus ging ik naar bed.
  • Ontwaakte, besloot "weet je wat, ik blijf bij Ubuntu" en besloot daarom om opnieuw te installeren vanaf dezelfde USB-stick. Deze keer heb ik GEEN schijf-encryptie gekozen, behalve dat, installeren was precies hetzelfde.
  • Installeren leek goed te gaan. Aan het einde heb ik de USB-stick verwijderd en opnieuw opgestart.
  • Systeembericht kwam met de melding "geen opstartbaar apparaat"
  • Re deed de installatie, hetzelfde probleem
  • Freaked out, besloot om mijn OpenSUSE thumbdrive te gebruiken om die distro te installeren, tijdens de installatie raadde OpenSUSE aan om alle bestaande partities van ubuntu etc te verwijderen, wat ik toestond. Installeren ging prima, maar na het verwijderen van thumbdrive en opnieuw opstarten krijg ik nog steeds: "geen opstartbaar apparaat"
  • Ik probeerde wat onderzoek te doen, sommige plaatsen gaven aan dat ik in legacy-bios-modus enz. Zou moeten zijn, maar op mijn oorspronkelijke installatie was ik op UETF en het was prima. Geprobeerd om dat in het BIOS te veranderen en opnieuw te starten. Ik ben een beetje verder (OpenSUSE-opdrachtregelitems zijn begonnen te verschijnen, dus ik denk dat het begon te laden) maar kreeg uiteindelijk weer een opstartbaar apparaatbericht.

Dus ik denk dat ik het hier verpest heb. Ik ga ervan uit dat dit iets te maken heeft met de eerste keuze om de harde schijf te versleutelen. Of ik heb de partitietabellen of iets dergelijks verknoeid.

Ik geef niets om verloren gegevens, alles wat ik nu wil doen, wordt in mijn Ubuntu USB thumbdrive gestopt, alle eerdere gegevens gewist en Ubuntu opnieuw helemaal opnieuw geïnstalleerd.

Ik zou stap voor stap echt waarderen. Ik voel me hier erg aan verloren.


1
2017-10-07 06:50


oorsprong


Gewoon voor de goede orde, het maken van een ubuntu USB-station en proberen uit te voeren, werkt niet? Werkt een live-cd? Dit kan zijn omdat er geen UEFI-partitie is. Als u uw bios kunt instellen op de legacy-modus, zou u ondanks de codering opnieuw moeten kunnen installeren (althans dat is wat ik denk). - don.joey
Hallo don.joey ---- Ik kan zonder problemen van de USB-stick rennen. Ook nog een stukje informatie: Wanneer ik OpenSUSE probeer te starten (vanaf de harde schijf), krijg ik de volgende boodschap: OpenSUSE is geblokkeerd door het huidige beveiligingsbeleid. Geeft dit verdere aanwijzingen? - user199467


antwoorden:


Geen opstartbaar apparaat betekent dat je grub niet hebt geïnstalleerd, niet de distro. Onthoud gewoon bij het klikken op van de / dev / sda partities en die in / dev / sdb als de partitie voor grub en alles zal in orde zijn.


0
2017-10-07 08:12



Het spijt me, zou je dat kunnen herhalen? Ik ben eigenlijk niet zeker wat je zegt = ( - user199467
Wanneer u installeert vanaf USB, selecteert u / dev / sdb1 als opstartbare partitie en waar grub is geïnstalleerd. - NotFromBrooklyn