Vraag Hoe kan ik Bluetooth deactiveren bij het opstarten van het systeem?


Hoe kan ik Bluetooth deactiveren bij het opstarten van het systeem?


277
2017-10-16 21:02


oorsprong


Ik denk niet dat "de natuurlijke standaardconfiguratie zou moeten zijn", mensen willen Bluetooth op hun computers gebruiken zonder het aan te zetten (je lijkt geen Bluetooth-muis of -toetsenbord te hebben, als dat jouw primaire invoerapparaten waarop u Bluetooth wilt inschakelen bij het opstarten). Ik ben het echter wel met je eens dat een manier om te kiezen hoe je wilt dat Bluetooth bij het opstarten is, handig zou zijn. - roadmr
Het normale en natuurlijke is om je in de bluetooth-instellingen te laten kiezen of je het wilt in- of uitschakelen wanneer het wordt opgestart. Het is niet vanzelfsprekend dat mensen het apparaat uit- of inschakelen telkens wanneer ze hun computer aanzetten. We hebben het over het maken van Linux tot het beste desktopsysteem, niet het ergste, toch? - Robert
We zijn het erover eens dat mensen laten kiezen de beste optie is. Zie hier voor enkele mogelijke manieren om dit te doen. answers.launchpad.net/ubuntu/+source/bluez/+question/51440 - roadmr
Dit is bug # 1073669. - colan
Het is ongelooflijk dat we op de 14e editie nog steeds Ubuntu-ontwikkelaars lesgeven, zoals "de optie om bluetooth aan of uit te schakelen tijdens het opstarten zou beschikbaar moeten zijn voor normale gebruikers, en niet alleen voor diegenen die dol zijn op zoeken in oneindige lijnen van openbare forums ". - Rodrigo


antwoorden:


18.04+ gebruikers die niet van nature een /etc/rc.local hebben, moeten er een maken en het uitvoerbaar maken. Om het iets eenvoudiger te maken, kunt u de volgende opdracht gewoon in een terminal plakken:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Rennen sudoedit /etc/rc.local en voeg dit toe vóór de regel met exit 0:

rfkill block bluetooth

U moet nog steeds Bluetooth kunnen inschakelen via de applet bovenaan.

Deze moeten werk voor de meeste systemen, maar het lijkt erop dat er een paar bugs op de loer liggen in de ACPI van de kernel voor Thinkpads. Als je een Thinkpad gebruikt, voeg je het volgende toe aan /etc/rc.local:

echo disable > /proc/acpi/ibm/bluetooth

Of uitchecken ibm-acpi - IBM ThinkPad ACPI Extras-stuurprogramma - sommige rapporten suggereren dat ibm-acpi onder meer bluetooth-besturing (onder andere leuke dingen) omvat. Maar ik heb de hardware niet, dus ik kan deze claims niet volledig verifiëren. Succes.


189
2017-08-18 09:00



Voor Thinkpads (en alleen Thinkpads) werkt dit: echo disable > /proc/acpi/ibm/bluetooth in /etc/rc.local - Marius Gedminas
rfkill block bluetooth werkte voor Thinkpad T430u - bmaupin
Noch werkte voor mij (ThinkPad x201) toen ik ze één voor één in plaatste /etc/rc.local. De rfkill block bluetooth opdracht werkt, maar niet bij opstarten. De vlag -x is ingeschakeld /etc/rc.local. Ik gebruik Xubuntu 13.10. - Kyle Falconer
Op Ubuntu 15.10 met systemd je hebt wat meer nodig om het gebruik van de. opnieuw in te schakelen etc/rc.local het dossier: askubuntu.com/a/696226/34298 - rubo77
als onze rc.local slechts een leeg bestand is, waar moeten we dan 'rfkill block bluetooth' toevoegen? - Sss


Ik vond een how-to met een schone "workaround" hier (archief link voor het nageslacht)

Eigenlijk aan het veranderen /etc/bluetooth/main.conf was genoeg voor mij.

Uit het artikel:

Zoeken naar het item:

InitiallyPowered = true

en verander de waarde in:

InitiallyPowered = false

Het was genoeg voor mij, hoewel het artikel een aantal andere stappen beschrijft die al dan niet noodzakelijk zijn.

Op Ubuntu 17.10 en Ubuntu 18.04 de optie InitiallyPowered is vervangen door AutoEnable


70
2018-06-25 18:00



werkt niet voor Samsung 530u3b, bluetooth is altijd ingeschakeld na opnieuw opstarten en wordt wakker - Maxim Kim
Dit zou alleen werken als ik ook Saeed Zarinfam's antwoord van putten gebruikte /etc/init.d/bluetooth stop in rc.local. Het lijkt erop dat wanneer de service wordt opgestart, deze ook de stroomtoevoer voor Bluetooth inschakelt. Ik had beide nodig om dit te laten werken. (ThinkPad x201, Xubuntu 13.10) - Kyle Falconer
Werkte niet voor mij op thinkpad t420 - UpTheCreek
"Zoeken naar de ingang" is van geen enkel nut voor degenen van ons wiens main.conf bevat deze parameter of een opmerking die de standaardlocatie aangeeft niet. Dus, waaronder [Heading] moeten we het zeggen? - underscore_d
In mijn geval was het AutoEnable = false, maar in ieder geval +1 voor de juiste oplossing vanaf de juiste plaats. - Arman Petrosyan


Om het bluetooth-stuurprogramma uit te schakelen bij het opstarten:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

toevoegen:

blacklist btusb

Later inschakelen zou gewoon moeten zijn:

sudo modprobe btusb

23
2017-08-18 16:59



Bedankt daarvoor, dat lijkt te werken, maar ik probeerde commandolijn dingen te vermijden zoals in mijn oorspronkelijke vraag. Je zou denken dat dit net zo eenvoudig zou zijn als het aankruisen van een vakje, zodat het herinnerde dat ik niet wil dat BT automatisch start, maar het ziet eruit als zijn ingewikkelder manier dan dat. Met Ubuntu's drive voor snellere opstarttijden en de algemene focus op stroomverbruik in laptops en netbooks, ben ik verrast dat dit nooit is aangepakt. Ik waardeer de hulp echter.
"Start gedit als root en bewerk /etc/modprobe.d/blacklist.conf" <- ok, is dat minder opdrachtregel voor je? - maco
Werkt prima op Samsung Q35 met Ubuntu 13.10, terwijl de 'rfkill block bluetooth'-benadering dat niet doet. Bedankt! - user27164
DELL E6410 werkt voor mij. Goed dat zonder herstart opnieuw kan worden uitgevoerd. - Ruslan Gerasimov
Probeer niet te proberen om "command line stuff" te vermijden wanneer u het besturingssysteem configureert. Zijn Ctrl + Alt + T en een paar ctrl-shift-V (te plakken) te veel om te vragen? - doug65536


Stap 1: Ga naar de terminal en typ de volgende opdracht om de systemen te bewerken /etc/rc.local het dossier:

gksudo gedit /etc/rc.local

Stap 2: Voeg de volgende regel toe vóór de exit 0 lijn:

rfkill block bluetooth

16
2018-05-04 20:44



Dit is een zacht blok voor bluetooth, ik denk dat het hetzelfde is als het uitschakelen van de service en het werkt goed. - Smile.Hunter
@Robert: $ man rfkill: "Schakel het apparaat uit dat overeenkomt met de opgegeven index."Ondanks de naam wordt BT alleen uitgeschakeld, probeer gewoon het commando rfkill block bluetooth op de terminal ziet u het pictogram grijs worden. - Daniel


Vanaf ubuntu 16.04 beheert systemd opstartservices zoals bluetooth ... om de huidige statusproblemen te bekijken die volgen in een terminal

sudo systemctl status bluetooth.service 

om dit te deactiveren bluetooth bij opstarten

sudo systemctl disable bluetooth.service

dan bij volgende reboot zal bluetooth niet actief zijn ... om bluetooth kwestie toe te laten

sudo systemctl enable bluetooth.service

12
2017-08-01 15:08



Dit werkt voor mij, maar als bijwerking stopte blueman-applet ook om te werken. Het begint, maar verschijnt niet in het indicatorgebied, dus er is geen snelle manier om bluetooth in te schakelen, alleen in de terminal. - Yuri Gor
Als je in Xubuntu op Blueman klikt, kun je "Schakel Bluetooth uit" uit. Ik denk dat dit is wat het OP graag geautomatiseerd zou willen hebben. Uw oplossing verwijdert Blueman helemaal, waardoor het moeilijker wordt om Bluetooth desgewenst opnieuw in te schakelen. - Adrian Keister
Zet sudo systemctl disable bluetooth.service && sudo systemctl stop bluetooth.service in een Disable script en chmod 755 erop. Doe hetzelfde voor sudo systemctl enable bluetooth.service && sudo systemctl start bluetooth.service in een Enable-script. - Adrian Keister


Typ het volgende in een terminal:

sudo gedit /etc/modprobe.d/blacklist.conf

Voeg onder aan het bestand de regel toe:

blacklist bluetooth

Sla het bestand op en start opnieuw op - Bluetooth zou nu moeten worden uitgeschakeld.


7
2017-10-16 21:25



Dit zal niet werken op mijn pc ... - Floqqi
@Floqqi: Kun je het opnieuw proberen? Ik heb mijn antwoord bijgewerkt. - Nathan Osman
Geprobeerd over 20 dingen op mijn ubuntu 12 thinkpad, dit is de enige die het lukte. - OlivierBlanvillain


U kunt de services bij het opstarten wijzigen met behulp van KONT.

Installeer het: sudo apt-get install bum

Rennen: sudo bum

enter image description here 

Verwijder het vinkje uit het selectievakje en klik Van toepassing zijn.


7
2018-05-05 00:09



Dank u, desgua, ik dacht aan dit soort hulpmiddelen. Ik heb er in het verleden wat gebruikt, maar ze zijn verouderd en de nieuwe ubuntu, met hun minimalistische obsessie, heeft niets van dien aard. Is dit de enige yo know of the best yo know? - Robert
Misschien werkt het, maar in eerste instantie heeft het me teleurgesteld omdat het de bluetooth begon te laten zien als niet geactiveerd tijdens het opstarten, waarom? en omdat de applet en hciconfig niet worden uitgevoerd als rfkill, wordt deze weergegeven. Ik zet het uit en weer aan, maar zwerver blijft de service als uitzetten. Ik heb de service bij het opstarten geactiveerd, maar de status van de service is nog steeds onjuist. - Robert
sorry werkt niet op elementaryOS Freya - Hoang Tran
Ik krijg veel "gebruik van niet-geïnitialiseerde waarde" -waarschuwingen wanneer het wordt uitgevoerd. Sorry, dat kan ik niet vertrouwen. - doug65536
Het pakket is nu niet beschikbaar. Er staat: Bum is virtueel. - Satya Prakash


Ik denk dat de beste manier is om te voorkomen dat de service in de eerste plaats wordt gestart. Er is een algemene methode voor het uitschakelen van services die perfect werkt:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

Dat werkt voor Ubuntu 13.10 en waarschijnlijk ook voor eerdere versies.


5
2018-01-18 09:49



hoe kan ik Bluetooth inschakelen, terwijl ik de meegeleverde instellingen later gebruik? Ik wil het gewoon 5 minuten gebruiken. elke 10 laarzen .. - b1r3k


ik voeg toe

"/etc/init.d/bluetooth stop"

in

"/etc/rc.local" 

voor "exit 0" commando voor opstarten met Bluetooth uitgeschakeld.


5
2017-08-23 13:00



dit werkte voor mij, bedankt! - woohoo
Hierdoor is het Bluetooth-pictogram in het systeemvak verwijderd maar bleef mijn Bluetooth-indicatielampje branden (met de aanduiding dat de voeding nog naar de radio werd verzonden). Bewerken: dit in combinatie met het antwoord van Stepbaer (InitiallyPowered = false) werkte voor mij. (ThinkPad x201, Xubuntu 13.10) - Kyle Falconer
dit werkte niet op mijn 64-bits Ubuntu 14.04 Dell Inspiron. Alleen rfkill werkte voor mij. - faizal