Vraag Waar is de Tidy 5.6 deb voor Linux


Ik heb geprobeerd netjes te installeren:

sudo apt install tidy

maar het zei dat het afhing van een versie van libtidy die ouder is dan degene die momenteel is geïnstalleerd:

De volgende pakketten hebben niet-afhankelijke afhankelijkheden: opruimen: Afhankelijk van:   libtidy5 (= 1: 5.2.0-2) maar 1: 5.4.0-1 + ubuntu16.04.1 + deb.sury.org + 1 is   worden geïnstalleerd

Ik probeerde toen het binaire bestand van de nieuwere versie van tidy (5.6) te downloaden, maar ondanks dat het in 2017 wordt uitgebracht, lijkt er geen DEB-download te zijn. Er is broncode, maar ik weet niet zeker hoe ik voor Linux moet bouwen.

Enig idee waarom er geen DEB-versie van Tidy 5.6 is en waarom er een pakket in apt is met een afhankelijkheid die verouderd is?


1
2017-08-19 14:49


oorsprong


OK bouwen vanuit de bron was eenvoudig, maar de bovenstaande vragen blijven. - bluppfisk
Het voorvoegsel deb.sury.org lijkt niet een officieel deb-pakket. U kunt het zelf controleren met apt-cache policy tidy libtidy5. Libtidy5-pakket is beschikbaar voor kunstig en nieuwer. - N0rbert
ah, dus ik heb per ongeluk libtidy5 ergens anders uit een andere bron geïnstalleerd? Ik kan me niet echt herinneren dat ik dat heb gedaan .. - bluppfisk
De uitvoer van apt-cache policy tidy libtidy zal de waarheid onthullen :) - N0rbert
Ja, zo lijkt het, of een ander pakket. In ieder geval weet ik niet precies waarom er geen deb-versie van nette 5.6 is - bluppfisk


antwoorden: