Vraag Unity Tweak-tool kan niet beginnen met de fout "com.canonical.unity.webapps-schema ontbreekt"


enter image description here

com.canonical.unity.webapps
  Om goed te werken, raadt Unity Tweak Tool aan dat u de nodige pakketten installeert


65
2018-04-18 17:29


oorsprong


Ik heb een screenshot van het probleem geüpload. Bekijk het alsjeblieft. - Muddassir Nazir
-1 voor degene die de foutmelding heeft geschreven. Bah. (als ze alleen a bestandsnaam je zou het kunnen proberen apt-file search). - Rmano
@Rmano deden ze, ik vond het prima met apt-file search. de volledige bestandsnaam is com.canonical.unity.webapps.gschema.xml; misschien moet je rennen sudo apt-file update? - mchid


antwoorden:


Installeer het pakket unity-webapps-service


80
2018-04-18 17:49



Ik heb hetzelfde probleem maar kan het pakket niet installeren. Ik krijg de volgende foutmelding: De volgende pakketten hebben niet-afhankelijke afhankelijkheden. unity-webapps-service: Afhankelijk van: webapp-container - Mrokii
sudo apt-get installeer unity-webapps-service IS juiste opdracht - Pratik C Joshi
Ik wil geen webapps op mijn desktop-pc ... Waarom kan ik geen tweak-tool gebruiken zonder een volledig nutteloze Ubuntu-browser - Kaspar
@Florian: Wow! Voor mij trok dat 120 MB aan qt-afhankelijkheden. - ccpizza
Betekent dit dat het pakket voor Unity Tweak Tool dit pakket als een afhankelijkheid moet hebben, maar niet? - andrybak


Gewoon een opdrachtregel manier om het antwoord van jackyzy823 te doen:

mkdir tweak;cd tweak
sudo apt-get download unity-webapps-service
ar xvf *
tar xvf data*
sudo mv usr/share/glib-2.0/schemas/com.canonical.unity.webapps.gschema.xml /usr/share/glib-2.0/schemas/
sudo glib-compile-schemas /usr/share/glib-2.0/schemas/
cd ..; sudo rm -Rf tweak

18
2017-07-28 10:11



Mooi! Werkt als een charme als je de webapps-service niet kunt laten installeren. Bedankt. - Andrew Fielden
Bedankt, ik heb beide antwoorden geactualiseerd. Gewoon een suggestie, hoewel: misschien wilt u aangeven welk antwoord u bedoelt met 'hierboven' - in dit geval het antwoord van jackyzy823. - Hitechcomputergeek
In mijn geval heb ik niets geïnstalleerd. Mijn thema en aangepast pictogrampakket stopten willekeurig met werken en keerde terug naar de standaard. Proberen om het opnieuw te configureren met Unity Tweak Tool is mislukt met dezelfde fout als het OP. Dit antwoord loste het op. - Nahuel
In mijn geval kreeg ik deze foutmelding omdat ik de fout niet heb notify-osd pakket geïnstalleerd; ik gebruik xfce4-notifyd in plaats daarvan. Dus mijn oplossing was precies zoals @mchid uitlegde, alleen ik heb gedownload notify-osd in plaats van unity-webapps-service. Werkt perfect. - Jonathan Landrum


Een lastige manier om dit te doen, omdat ik niet zoveel afhankelijkheden voor wil downloaden unity-webapps-service.

pak het bestand uit com.canonical.unity.webapps.gschema.xml (je kunt het zien http://packages.ubuntu.com/trusty/amd64/unity-webapps-service/filelist) in pakket unity-webapps-service, zet dit bestand op /usr/share/glib-2.0/schemas/ en tenslotte sudo glib-compile-schemas /usr/share/glib-2.0/schemas/ en het werkt.


14
2018-05-26 03:37



Bedankt! Dit is het beste antwoord, omdat unity-webapps-service weigert te worden geïnstalleerd. - Sumit Jain
Waar vind ik het schemabestand? - thesdog
@thesdog ga hierheen packages.ubuntu.com/trusty/unity-webapps-service. Download het deb-pakket en pak het uit met behulp van de instructies in de onderstaande post door mchid. - Andrew Fielden


Eenvoudige oplossing.

Installeer de benodigde pakketten.

sudo apt-get install unity-webapps-common

10
2017-10-01 14:16



Het installeren van deze package lost het probleem op. Tenminste voor 14.10. - Grzegorz Żur
Ik krijg de volgende foutmelding: The following packages have unmet dependencies: unity-webapps-common : Depends: unity-webapps-service (>= 2.3.8-0ubuntu3) but it is not going to be installed E: Unable to correct problems, you have held broken packages.  Synaptic zegt dat ik geen kapotte pakketten heb. - Marc
hoe wist je dat je moest installeren? unity-webapps-common ? Het wordt helemaal niet vermeld in het foutscherm dat wordt weergegeven in OP. Is het mystieke kennis die naar je toe komt als je slaapt? - frumbert


Voor diegenen die nog steeds een oplossing nodig hebben: het probleem doet zich voor als men de overlay-schuifbalken verwijdert. Om het probleem op te lossen installeert u de overlay-schuifbalken opnieuw (sudo apt-get installeren overlay-schuifbalk) en schakelt u deze uit via de Unity Tweak Tool zelf. (Systeem-> Scrolling)


2
2018-02-08 07:54





Eenvoudig en effectief type

sudo apt-get install unity-webapps-common unity-webapps-service

naar de terminal


1
2018-04-25 01:22



ja..geloof, dat antwoord is al eerder gegeven. Het installeren van unity-webapps-service is voldoende. - Muddassir Nazir


Ik had geen probleem om webapps-service en webapps vaak te installeren. Mijn exact probleem was het pakket

 com.canonical.unity.FileLens

was vermist. Ik heb de schermafbeelding in deze vraag verkeerd gelezen en heb meer dan een half uur besteed aan het proberen te achterhalen waarom, hoewel eenheid webapps-service en webapps gemeenschappelijk zijn geïnstalleerd, eenheid tweak-tool niet werkt. Eindelijk kwam ik erachter dat het bovenstaande pakket ontbrak in plaats van degene die in het screenshot wordt genoemd.

Om deze fout op te lossen, installeert u de unity-lens-files pakket

sudo apt-get install unity-lens-files

Dat is het. Unity Tweak Tool werkt nu! (Tenslotte!)


1
2017-10-11 14:37





Dit is voor (zanna / phoenix) die reageren Om "com.canonical.unity.FileLens" op te lossen DOE DIT sudo apt-get installeer eenheid-lens-bestanden BEDANKT

Om "com.canonical.notify.osd" op te lossen ik deed apt-get install notify-lens WERKT FLAWLESSLY


0
2017-12-04 04:45





U moet synaptic gebruiken. Probeer deze:

  1. Installeer synaptic: "sudo apt-get install synaptic" in de terminal.
  2. Open Synaptic vanuit het dashboard of vanuit de sudo-synaptische terminal.
  3. Klik op Aangepaste filters en vervolgens Ontbrekende Aanbevolen Pakketten.
  4. Markeer alles en klik met de rechtermuisknop voor installatie
  5. Klik op toepassen op de werkbalk.

0
2017-12-04 05:33





Het installeren van unity webapps is onmogelijk omdat de afhankelijkheden worden verbroken vanwege incompatibiliteit met ubuntu 15.04


-1
2017-10-04 03:33



Wat is onmogelijk? - Seth♦
nou, we hadden het over Trusty. Je bent te laat. Ik heb dit in april vorig jaar gepost. - Muddassir Nazir