Vraag gedit `Comment Code` plugin geïnstalleerd, maar werkt niet


Ik heb geen problemen met het installeren van GEdit-plug-ins en over het algemeen lijkt GEdit goed te werken. Het lijkt er ook op dat de plug-ins zijn geïnstalleerd (in ieder geval tot op zekere hoogte) omdat het Reactie code en Uncomment-code opties verschijnen op het tabblad Bewerken.

Het enige probleem is dat deze commentaarfuncties grijs worden weergegeven en Ctrl+M heeft ook geen effect. Hoe kan ik dit oplossen?


1
2017-12-13 16:55


oorsprong


Welke plug-in bedoel je? - A.B.
Het is de "Code Comment" -plug-in, maar ik heb het geïnstalleerd als onderdeel van een reeks standaard plug-ins met sudo apt-get install gedit-plugins zoals aanbevolen bij delightlylinux.wordpress.com/2015/05/22/... - zkurtz
Kunt u alstublieft een bestand opgeven waarvoor het niet werkt? Het moet natuurlijk een taal zijn die door de plug-in wordt herkend. - dadexix86
@ dadexix86, wat voor jou duidelijk is, was mij niet. Ik zal je krediet geven als je als een oplossing post. Ik probeerde het op een vlak tekstbestand zonder extensie, ervan uitgaande dat het standaard op # zou moeten staan, maar het werkt prima zodra ik een specifieke taalextensie toevoeg. - zkurtz
Gedaan! :) Inderdaad, het staat standaard op Geen. Als je erover nadenkt, heeft het geen zin om de voorkeur te geven aan de ene stijl van commentaar boven de andere. - dadexix86


antwoorden:


Het bestand dient van gedit te zijn, zodat de plug-in weet welke opmerkingen hij moet gebruiken (#, --, <--...>, /*...*/, ecc ...)


1
2017-12-13 22:21



om mezelf als beginnelingen perfect duidelijk te maken voor beginners, door te vertellen wat de te gebruiken taal is, is het net zo eenvoudig als het opnemen van de standaard taalextensie in het bestand dat je aan het bewerken bent. Zo myfile.py als je python doet, of myfile.R als je R aan het doen bent, etc. - zkurtz