Vraag Het installeren van nvidia-modprobe op Ubuntu 14.04 veroorzaakt bevroren splashscherm bij het opstarten


Dus voor onderzoek moet ik CUDA 7.5 installeren dat alleen werkt met nvidia-352 en hoger, dus ik heb de aanbevolen aanpak gevolgd vanuit dit artikel:

BinaryDriverHowto / Nvidia - Officiële Ubuntu-documentatie

Mijn grafische kaart is Nvidia GeForce 750M, dus ik heb versie 352.63 geïnstalleerd. Tot zover goed. Maar toen ik nvidia-modprobe installeerde omdat cuda het nodig heeft, krijg ik vlak na het opnieuw opstarten het paarse splashscherm van de dood.

Dus natuurlijk heb ik mijn laatste stap omgekeerd: ik heb nvidia-modprobe leeggemaakt in de herstelmodus en opnieuw gestart - wonderbaarlijk genoeg. Het opstartscherm is verdwenen. Ik geloofde mijn geluk niet, dus heb ik dit probleem meerdere keren herhaald, telkens als het naar nvidia-modprobe verwijst.

Aangezien ik nvidia-modprobe nodig heb voor projecten, maar het veroorzaakt een fout tijdens het booten, kan ik de fout omzeilen door deze te verwijderen voordat ik opnieuw opstart. Maar waar kwam dit probleem in de groene aarde van God vandaan? Ik heb geprobeerd een oplossing te vinden maar kon die niet vinden.

Ik zie dat wanneer het nvidia-modprobe installeert, het stuurprogramma-versie 340 probeert te gebruiken, maar ik heb geprobeerd een overeenkomende 352-versie in de ubuntu-softwarebibliotheek te vinden en kon niets vinden.

Preparing to unpack .../nvidia-modprobe_340.24-1~ubuntu14.04.1_amd64.deb ...
Unpacking nvidia-modprobe (340.24-1~ubuntu14.04.1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up nvidia-modprobe (340.24-1~ubuntu14.04.1) ...

1
2018-03-08 03:19


oorsprong




antwoorden:


Ik kreeg hetzelfde probleem. Mijn oplossing is:

  1. Verwijder nvidia-modprobe.
  2. Gebruik dit script: http://docs.nvidia.com/cuda/cuda-installation-guide-linux/#runfile-verifications.

1
2018-04-16 14:41