Vraag "Vereist installatie van niet-vertrouwde pakketten" tijdens het upgraden met de updatebeheerder


screenshot

Het heeft de fout niet verholpen. Dus, hoe los ik mijn GUI-update op?

Voor elke software moet ik het vanaf de opdrachtregel installeren omdat ik dezelfde foutmelding kreeg bij het installeren van de software van Ubuntu Software Center.


66
2018-03-29 11:55


oorsprong


Op softwarebronnen, Ubuntu-softwaretabblad verandert de parameter "downloaden van" gewoon in "Server voor España". Dat werkte voor mij.
het antwoord is voorbij hier Het werkte heel goed voor mij. - bademba


antwoorden:


  1. Schrijf in een terminal: sudo apt-get update && sudo apt-get upgrade of wijzig de instellingen van Update Manager (probeer dit eerst als u Update Manager al hebt geconfigureerd).

    CLI

  2. Start Update Manager en probeer het opnieuw.

    GUI

Update uitvoeren via een terminal geeft de optie om niet-vertrouwde pakketten toe te staan ​​of te weigeren.

WARNING: The following packages cannot be authenticated!
  playonlinux
Install these packages without verification [y/N]?

Als u de pakketbron vertrouwt, typt u y.


64
2018-03-29 17:14





Dit gebeurt door het missen van sommige GPG-sleutels. Om dit op te lossen, opent u een terminal en voert u de onderstaande opdrachten uit:

sudo apt-get update

U krijgt een foutmelding dat een openbare sleutel niet beschikbaar is. Let op de sleutelstring (na de NO_PUBKEY; bijv .: D6B6DB186A68F637)

 gpg --keyserver keyserver.ubuntu.com --recv XXXXX

Vervang de XXXXX door de sleutelstring

bijv .: gpg --keyserver keyserver.ubuntu.com --recv D6B6DB186A68F637

gpg --export --armor  XXXXX | sudo apt-key add -

bijvoorbeeld: gpg --export --armor D6B6DB186A68F637 | sudo apt-key add -

sudo apt-get update

Probeer nu uw systeem opnieuw bij te werken.

Hier is een vergelijkbaar bericht: "Vereist om niet-vertrouwde updates te installeren" Fout in Update Manager

Ik hoop dat dit helpt.


43
2017-12-01 09:05



geprobeerd dit en ik kreeg het bericht dat er iets is gemaakt, maar de update functioneerde nog steeds niet. Maar de optie van Evgeny werkte, dus het is niet nodig om problemen op te lossen die fout zijn gegaan met je voorstel. - rumtscho
sorry, rumtsho. Ik ben vergeten in mijn antwoord het commando 'gpg --export' toe te voegen. Ik heb mijn antwoord bijgewerkt. Probeer het gewoon. en controleer of de update werkt of niet. - aneeshep
hmm, ik snap het gpg: keyserver timed out; suggesties? - gatoatigrado
Kan ook gebruiken sudo apt-key adv --recv-key --keyserver keyserver.ubuntu.com XXXXXXXXX van askubuntu.com/questions/71188/... - pd12


U kunt het via de opdrachtregel installeren: sudo apt-get install --allow-unauthenticated exiv2.

Om de repo permanent te "vertrouwen", voer je dit uit: sudo apt-add-repository ppa:pmjdebruijn/darktable-release && sudo apt-get update. Ik geloof dat dat de PPA is die u gebruikt.


13
2017-12-01 09:12



Bedankt, het "blijvend vertrouwen in de repo" is wat ik wilde bereiken en het werkte. Ik vraag me gewoon af waarom het schrijven van het adres in de sources.list het niet vertrouwd, maar apt-add-repository wel. - rumtscho
Alle pakketten worden ondertekend met een cryptografische sleutel, het "vertrouwen" van de repo houdt in dat de publieke sleutel voor die repository wordt opgehaald. U kunt lezen over cryptografie met openbare sleutels op Wikipedia. - evgeny


In antwoord op uw vraag, u kan niet "repareren" van de GUI-update (dat wil zeggen Update Manager), omdat het duidelijk is dat die applicatie momenteel niet de mogelijkheid heeft om niet-vertrouwde pakketten te installeren. Als u niet-vertrouwde pakketten wilt installeren, moet u dit doen op de opdrachtregel.

Er zijn echter twee manieren waarop u kunt voorkomen dat Update Manager deze fout meldt: verwijder de niet-vertrouwde software van uw systeem OF vertrouwen de repository in kwestie, zoals uiteengezet in het antwoord op de andere vraag ( Updates worden niet geïnstalleerd vanwege "niet-vertrouwde pakketten" ).

De eerste stap is om erachter te komen welke repository het probleem veroorzaakt. Je kunt dit achterhalen door te typen apt-cache policy ambiance-colors op de opdrachtregel.

Echter, een snelle Google onthult dat ambiance-colors en radiance-colors zijn van ppa:ravefinity-project. U zou dus in staat moeten zijn om uw probleem op te lossen door te typen

sudo add-apt-repository ppa:ravefinity-project/ppa
sudo apt-get update
sudo apt-get install ambiance-colors radiance-colors

genomen van http://www.webupd8.org/2012/01/ambiance-and-radiance-colors-theme-pack.html


5
2018-06-10 20:06





waarom het zeggen op die manier betekent dat de pakketten die u probeert te installeren, software van derden zijn. Dus als u ze wilt installeren, schakel dan het Canonical-selectievakje bij andere softwaretabbladen in de instellingen van updatebeheer in en probeer vervolgens opnieuw te installeren.

hoop dat het helpt.


1
2018-03-29 17:21





Ik had hetzelfde probleem. Voor mij werkte dit commando:

sudo apt-get update --fix-missing

Het voordeel hiervan ten opzichte van de andere oplossingen is de eenvoud. U kunt doorgaan met het gebruik van de GUI en hoeft niet te achterhalen welke repository is gebroken. Ik heb de oplossing gevonden hier in een opmerking. Ik ken Ubuntu niet genoeg om uit te leggen, maar ik veronderstel dat het de sleutels krijgt die nodig zijn om alle repo's te laten werken.


1
2017-09-20 08:58





Uw vraag is onduidelijk: u "herstelt uw GUI-update" door de fout te herstellen. De andere vraag zal je laten zien wat je moet doen.

U kunt het deselecteren van alles waarvan uw updates op een niet-vertrouwde bron vertrouwen, of u kunt doorgaan en de opdrachtregel gebruiken om die specifieke bron permanent te vertrouwen. Zodra je een van deze hebt gedaan, verschijnt het bericht niet meer. Als u de laatste doet, verschijnt het bericht nooit meer voor die specifieke bron.


0
2018-03-29 17:04