Vraag Probeert php7 te installeren


Probeert een lampinstallatie te doen Ik krijg de volgende foutmelding:

$ sudo apt-get install libapache2-mod-php7.0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libapache2-mod-php7.0 is already the newest version (7.0.15-0ubuntu0.16.04.4).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up libapache2-mod-php7.0 (7.0.15-0ubuntu0.16.04.4) ...
dpkg: error processing package libapache2-mod-php7.0 (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 libapache2-mod-php7.0
E: Sub-process /usr/bin/dpkg returned an error code (1)

1
2018-03-04 07:30


oorsprong


voeg alsjeblieft meer informatie toe, zoals je hebt gedaan, want als ik het zie vanuit jouw opdracht, zegt het me Ik heb php7 geïnstalleerd en bij het installeren van "libapache2-mod-php7.0 module" krijg ik een foutmelding... DUS, het is of u probeert het te installeren module eerst eerder PHP7 of je hebt en krijgt fouten bij het installeren van de betreffende module - George Udosen
Er is "1 niet volledig geïnstalleerd of verwijderd." Dus probeer het met sudo apt install -f naar repareren kapot, daarna sudo apt update && sudo apt upgradeen probeer het opnieuw sudo apt install libapache2-mod-php7.0. - pa4080
Volledige opdracht was als volgt: $ sudo apt-get install php7.0 php7.0-mysql libapache2-mod-php7.0 php7.0-cli php7.0-cgi php7.0-gd - Edward Danilyuk
Ook kun je dit pakket opschonen en probeer het opnieuw te installeren: sudo apt purge libapache2-mod-php7.0. - pa4080
Spas: apt purge en install hebben de truc gedaan. Dank je! - Edward Danilyuk


antwoorden:


Zoals vermeld in deze opmerking

sudo apt purge libapache2-mod-php7.0

werkte ook voor mij.


1
2017-12-16 01:40