Vraag Lelijke lettertypen in Netbeans - Hoe kan ik ervoor zorgen dat het het systeemlettertype gebruikt?


Ik heb problemen om het lettertype Netbeans er leuk uit te laten zien, dit is een probleem sinds ik Ubuntu ~ 8 heb geprobeerd. Om een ​​of andere reden zien lettertypen eruit dat ze niet alleen subpixels in Netbeans krijgen, maar voor de rest van de toepassingen zien ze er perfect uit.

Kijk hoe lelijk het screenshot is:

enter image description here

Het is niet alleen het codegebied, maar elk lettertype in de toepassing ziet er zo uit. Ik keek rond en blijkbaar voegde ik de volgende regel toe aan de .bashrc bestand zou het probleem moeten oplossen, maar in mijn geval deed het dit niet:

export _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=lcd'

Het lijkt erop dat dit alleen van invloed kan zijn op op Java gebaseerde applicaties, maar ik heb nog geen andere Java-app kunnen testen om de lettertypen uit te checken.

Weet iemand wat kan ik doen om dit op te lossen? Hoe kan ik Netbeans het systeemlettertype laten gebruiken?


67
2018-03-30 05:58


oorsprong


Ik heb ook gekeken en gezocht naar een oplossing hiervoor, maar er lijkt er geen een te zijn. Specifiek heeft het invloed op Swing-gebaseerde applicaties; je zult zien dat Eclipse er bijvoorbeeld prima uitziet. Ik ben eigenlijk niet zo druk bezig met het lettertype van de code (het is veranderlijk, en ik vind dat het er goed uitziet met Droid Sans Mono op 11pt), maar de verchroomde lettertypen schokken me echt. - Jamie Schembri
Ja, het lijkt alleen Java-gebaseerde apps te beïnvloeden, ik denk erover om mijn IDE te veranderen, alleen vanwege dit .. - Javier Villanueva
Eigenlijk noemde ik Swing specifiek omdat het lettertypeprobleem niet zichtbaar is in SWT-toepassingen, zoals Eclipse. Hoe het ook zij, het is echter alleen van invloed op (sommige) Java-toepassingen. Ook kan ik bevestigen dat het probleem nog steeds aanwezig is in Netbeans 7.0 RC1. - Jamie Schembri
Je hebt gelijk Ik ben overgestapt naar Aptana en ze zien er goed uit, ik hoop dat ik hiervoor een oplossing kan vinden. Ik hou echt van Netbeans, maar dat lettertype maakte me gek. - Javier Villanueva
Ik gebruik nu 'Droid Sans Mono', maat 16 met '-J-Dawt.useSystemAAFontSettings = on --laf javax.swing.plaf.nimbus.NimbusLookAndFeel -J-Dsun.java2d.noddraw = true -J-Dsun. java2d.dpiaware = true' - Karussell


antwoorden:


Zoals in de reacties is vermeld, is dit een probleem met Java Swing-apps op Linux. Swing gebruikt wel Gnome's font smoothing-instellingen (gedeactiveerd, grijsschaal of subpixel) - het negeert echter de hinting-instellingen. Het gebruikt altijd volledige hinting en als je Ubuntu gebruikt met weinig of geen lettertype-hinting (zoals de meeste mensen doen omdat weinig hint de standaardinstelling is), zal het lettertype er aanzienlijk anders uitzien dan in andere applicaties. SWT-applicaties zoals Eclipse zijn prima, maar als je NetBeans leuk vindt, zal dit je niet helpen.

Waarschuwing: voor de volgende oplossing heb ik het alleen over het lettertype van de editor, want in een IDE is dat wat belangrijk voor me is. Je zou het ook kunnen toepassen op de menu-lettertypen enz., Maar dat is misschien een beetje overdreven.

De enige bruikbare oplossing die ik heb gevonden hier : gebruik Fontforge om het gekozen lettertype van de editor te bewerken en alle informatie over de hints uit het lettertype zelf te verwijderen, sla het op als een nieuw lettertype en gebruik dat in Netbeans.

  1. sudo apt-get install fontforge
  2. Lancering fontforge
  3. Open uw lettertype naar keuze
  4. Ctrl+EEN of edit -> Select -> Select all om alle tekens te selecteren
  5. Tips ⇒ Duidelijke instructies
  6. Ctrl+Verschuiving+F of element -> font info om de informatie over het lettertype te openen
  7. Hernoem het lettertype (bijvoorbeeld naar de originele naam + '_nohints')
  8. Bewaar het bewerkte lettertype in de .fonts map in uw huis, via file -> generate fonts, zorg ervoor dat u een indeling gebruikt die Ubuntu leest (zie volgende stap)
  9. Cache voor lettertypen wissen fc-cache -rv - zijn uitvoer volgen om er zeker van te zijn dat uw nieuwe lettertype werd opgepakt (bijv. .sfd niet maar .ttf doet).
  10. Voer Netbeans uit en gebruik het lettertype dat u hebt aangemaakt als editorlettertype

Nee, niet perfect en ja, een beetje gedoe, maar toch een wereld van verschil. Ik hoop dat het helpt.


38
2018-04-21 21:12



ik gebruikte Monospace, de standaard in NetBeans. Ik heb geprobeerd het op te lossen Ubuntu Monospace, en het ziet er nu beter uit, maar nog erger dan Monospace. Toch bedankt. Als ik kon vinden Monospace locatie op het bestandssysteem, zou ik ook proberen het te repareren. - umpirsky
Heel erg bedankt ... De enige werkende oplossing die ik heb gevonden. Ik werd er gek van !! - Stefanos Kalantzis
Weet niet zeker welk lettertypebestand mijn lettertype is ... Heb 9 verschillende lettertypebestanden voor het Ubuntu-lettertype alleen, dus nodig om te raadplegen font.ubuntu.com om te bedenken welke je moet sleutelen. Ik hoop dat dit zal werken. - matt


Toevoegen

--laf Nimbus -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd

of

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd --laf Metal

naar het bestand: netbeans.config. Je kunt het vinden in de map $ NETBEANS_HOME / etc /. Maak uw applicatie-lettertype kleiner van systeemvoorkeuren.

Bron


16
2017-09-11 08:03



Het configuratiebestand staat meestal op /home/<user_name>/<neabeans_folder>/etc/netbeans.conf. - Bibhas
Werkte niet voor mij :( - szx
Het configuratiebestand bevindt zich in /etc/netbeans.conf De eerste regel werkte niet voor mij, maar de tweede deed de slag - Christian Vielma
Ik zie geen verschil na het toevoegen van deze regel. EEN . is nog steeds slechts één pixel, bijvoorbeeld waar het mooi wordt weergegeven in een andere app. - NoBugs
Deze heeft de truc voor mij gedaan. - P0rnflake


Ik weet dat dit een oude vraag is, maar in mijn zoektocht naar hetzelfde probleem, heb ik alle slagen geprobeerd zonder geluk. Ik dacht dat ik gewoon met vreselijke tekst in netbeans zou moeten leven.

Toen vond ik dit: http://youtrack.jetbrains.com/issue/IDEA-57233#comment=27-472038

Eigenlijk: Ubuntu 13.10, Netbeans (7.3), Infinality-lettertypepatches voor freetype, OpenJDK7 en patches om de slingering van lettertypen van Swings op te lossen. En het "werkte gewoon" !!!

Hier gekopieerd voor het geval dat de link sterft:

  1. installeer freetype

    $ sudo apt-get install libfreetype6
    
  2. installeer infinaliteitspatch

    $ sudo add-apt-repository ppa:no1wantdthisname/ppa
    $ sudo apt-get update
    $ sudo apt-get install fontconfig-infinality
    

    Ik moest daarna het volgende doen:

    $ sudo rm /etc/fonts/conf.avail/52-infinality.conf
    $ sudo ln -s /etc/fonts/infinality/infinality.conf /etc/fonts/conf.avail/52-infinality.conf
    

    Om Windows 7 te gebruiken zoals font rendering doe je het volgende:

    $ sudo /etc/fonts/infinality/infctl.sh setstyle win7
    

    Stel USE_STYLE in op "WINDOWS7" in /etc/profile.d/infinality-settings.sh

  3. installeer lettertype vaste OpenJDK

    $ sudo add-apt-repository ppa:no1wantdthisname/openjdk-fontfix
    $ sudo apt-get update
    $ sudo apt-get install openjdk-7-jdk
    

    In .../etc/netbeans.conf,

    netbeans_default_options bestaat uit: -J-Dawt.useSystemAAFontSettings=lcd en -J-Dsun.java2d.xrender=true"

    En instellen netbeans_jdkhome="/usr/lib/jvm/java-1.7.0-openjdk-amd64"

Dit veranderde mijn Netbeans-lettertypen van de acceptabele, moderne tot de moderne dag van 1990. En ik kan de Inconsolata nu gebruiken als het lettertype van mijn Netbeans-editor en het ziet er GEWELDIG uit.

Schermopname zoals gevraagd: (de werkelijke tekst is duidelijker dan deze opname. Iets in de opname maakte het enigszins wazig). enter image description here


7
2018-01-31 05:28



als een voetnoot: de "-J-Dsun.java2d.xrender = true" introduceerde enkele render glitches. zet het op false, corrigeerde de render glitches bij snel scrollen, maar had geen impact op de mooie lettertypen. - Chris Holt
Een snelle vervolgnotitie: als de openjdk pacakage voorafgaand aan het lettertype is bijgewerkt en u past het toe, kunt u dit terughalen: voor openjdk-7-jdk, openjdk-7-jre en openjdk-7-jre-headless , verwijder ze en installeer vervolgens de vorige versies van de repository voor het herstellen van lettertypen. apt-cache policy <package> zal je de versies tonen. d.w.z. apt-get remove openjdk-7-jdk openjdk-7-jre openjdk-7-jre-headless apt-get install openjdk-7-jdk=7u51-2.4.4-0ubuntu0.13.10.1ppa2 openjdk-7-jre=7u51-2.4.4-0ubuntu0.13.10.1ppa2 openjdk-7-jre-headless=7u51-2.4.4-0ubuntu0.13.10.1ppa2 - Chris Holt
kun je een afbeelding bijvoegen, hoe het er nu uitziet? - Roman


De anti-aliasing van de lettertypen werkt niet goed in Ubuntu Java Swing-toepassingen.

Toevoegen:

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd

naar netbeans.config aan het einde van de netbeans_default_options draad.

Je vindt het configuratiebestand in de map $ NETBEANS_HOME / etc / (bijv. /home/<user_name>/<neatbeans_folder>/etc/netbeans.conf)

Voorbeeld:

netbeans_default_options="-J-client -J-Xss2m -J-Xms32m -J-XX:PermSize=32m -J-Dnetbeans.logger.console=true -J-ea -J-Dapple.laf.useScreenMenuBar=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.java2d.noddraw=true -J-Dsun.java2d.dpiaware=true -J-Dsun.zip.disableMemoryMapping=true -J-Dnetbeans.extbrowser.manual_chrome_plugin_install=yes -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd"

5
2018-01-24 09:53



Voor mij was het configuratiebestand te vinden op /etc/netbeans.conf (en vanuit andere plaatsen gesynchroniseerd). - Cedric Reichenbach
Schijnbare bron: rdeeson.com/weblog/159/fix-ugly-fonts-in-netbeans-under-linux - werkte voor mij - loxaxs


Het is niet zo erg dat lettertype ..

Dit is echter een Java-toepassing en als een speciale manier om lettertypen te verwerken.

Als u alleen de tekengrootte wilt wijzigen, kunt u Netbeans starten met "--fontsize" parameter:

netbeans --fontsize 12

Als u het lettertype wilt wijzigen, is het een beetje moeilijker omgevingsparameters aan te passen, en dit artikel legt heel goed uit:

https://wiki.archlinux.org/index.php/Java_Runtime_Environment_Fonts

Dit is voor ArchLinux maar ik denk dat het ook in Ubuntu zal werken, omdat Java een universele software is.


2
2017-10-10 21:52





Ik had hetzelfde probleem op Ubuntu 12.04 en Netbeans 7.2.

Ik heb geprobeerd toe te voegen -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd naar netbeans.conf maar het loste het probleem niet op.

Toen zag ik de kwestie opmerking met betrekking tot de regelhoogte op Netbeans-bug 215785. De bewerkingslijnhoogte instellen op 1.0 samen met AA-instellingen in netbeans.conf mijn probleem opgelost.


2
2017-09-01 13:48





Ik kon dit op dezelfde manier doen (ik gebruik ook Ubuntu 12.10, werkte ook aan Ubuntu 13.04):


Stap 1 (Dit werkt waarschijnlijk in alle Ubuntu-versies):

Eerst heb ik de menu's opgeruimd met behulp van deze plug-in Tools -> Plugins -> Settings -> Add:

http://java-swing-ayatana.googlecode.com/files/netbeans-catalog.xml

Zodra die locatie is toegevoegd, moet u de plug-in installeren door te zoeken naar Java Ayatana (de beschrijving zal in het Spaans zijn). Hierdoor worden het hoofd- en contextmenu hetzelfde als het besturingssysteem.


Stap 2 (Ik weet niet of dit in alle Ubuntu-versies werkt):

Vervolgens wilt u waarschijnlijk ook dat de projectlettertypen er mooier uitzien, wat ik heb gedaan om dit probleem op te lossen dat in de terminal werd uitgevoerd: sudo apt-get install gnome-tweak-tool Ik heb het gelanceerd en koos een ander default font Nu ziet Netbeans er mooi uit!

Hier is een screenshot:

enter image description here


1
2017-12-22 22:49



Het wijzigen van het lettertype 'Interface' op de tweak-tools heeft de truc voor mij gedaan. Ik had alleen problemen met die teksten (gehalveerd!) - Makiavelo


Ik zag deze berichten en probeerde mijn probleem met lettertypen op te lossen, ik had ook problemen, ik kon slechts 4 lettertypen kiezen die allemaal zwak waren, en vroeg me af wat er gebeurde dat netbeans slechts 4 lettertypen gaf om uit te kiezen en ook lame font chooser box, ik ben een grote fan van netbeans en ik wist dat ik hier een oplossing kon vinden.

elke manier waarop ik alle mogelijke gidsen volgde. Ik gebruik Ubuntu 13.10 en Netbeans 7.3 (ja ik hou van de onstabiele dingen)

  1. maak een .font-map in mijn gebruikersmap.
  2. alle lettertypen gekopieerd die ik naar die map had.
  3. de volgende regel toegevoegd aan het bestand netbeans.conf

vind het door te draaien:

locate netbeans.conf

bewerk het en voegde het volgende toe aan de offertes zoals hierboven gesuggereerd

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd --laf Metal
  1. voer netbeans update uit waarvan ik denk dat het de magie deed nu heb ik een mooie lettertype-kiezer en heb meer lettertypen om te kiezen dan code om te schrijven (ongebruikelijke grap).

Ik hoop dat het je zal helpen.


1
2018-01-01 14:24





#!/bin/sh

gsettings set org.gnome.desktop.interface font-name 'Ubuntu 10'
sh /home/xxx/netbeans-7.2/bin/netbeans &
sleep 5
gsettings set org.gnome.desktop.interface font-name 'Ubuntu 11'

0
2017-09-19 11:53



Welkom bij Ask Ubuntu! Dit antwoord zou substantieel profiteren, als je het zou bewerken om wat uitleg toe te voegen (of in ieder geval om de gebruiker precies te vertellen wat moeten we doen met deze regels). - Eliah Kagan


Persoonlijk denk ik dat de algehele standaard verschijning van Netbeans op Linux een beetje teleurstellend is, vooral als je bedenkt hoe mooi het eruit ziet op andere platforms. Gelukkig is het veranderen van de look & feel (LAF) gemakkelijk vanuit de IDE. Afhankelijk van uw selectie, verbetert dit vaak het uiterlijk van lettertypen.

Om de LAF te veranderen, doe je het volgende: Klik op Extra >> Opties Selecteer in het dialoogvenster Uiterlijk en vervolgens het tabblad Uiterlijk Selecteer gewoon een van de LAF's. Mijn voorkeur gaat uit naar Nimbus, maar misschien heb je liever iets anders.

Er zijn ook twee 'Dark LAFs' plug-ins beschikbaar: Dark Metal en Dark Nimbus.


0
2017-07-24 01:12