Vraag Software Updater - Probleem na Calibre-upgrade


Ik ben hier nieuw, dus sorry als dit niet de juiste plek is om te posten.

Ik gebruik Calibre onder Ubuntu 16.04 LTS. Onlangs besloot ik om te upgraden van de versie die via de offi werd gedistribueerdbenadrukte tekstciale Ubuntu-opslagplaatsen (2.85.1) tot de laatst beschikbare (3.12.0). Om dit te doen volgde ik de methode beschreven in https://calibre-ebook.com/download_linux ("Binaire installatie").

Caliber lijkt zelf een upgrade te hebben gekregen, maar sinds ik dit heb gedaan krijg ik steeds een foutmelding wanneer ik Ubuntu Software Updater uitvoer. Hierop staat een pakket met de naam "E-book converter en bibliotheekbeheer", dat duidelijk gerelateerd is aan Calibre.

Onder het tabblad "Technische beschrijving" / "Wijzigingen" voor dit pakket kan ik het volgende lezen:

"Wijzigingen voor versies van kalibers-bakken:   Geïnstalleerde versie: 2.55.0 + dfsg-1   Beschikbare versie: 2.85.1-1 ~ getdeb1 Deze update is niet afkomstig van een   bron die changelogs ondersteunt. "

Als ik probeer het pakket te installeren, kom ik terecht in het Ubuntu-foutbericht

"Vereist installatie van niet-vertrouwde pakketten - Dit vereist   het installeren van pakketten van niet-geverifieerde bronnen ".

Kan iemand erachter komen wat ik moet doen om de installatie van dit pakket te voltooien (of om het foutbericht te vermijden elke keer dat ik Ubuntu update)?

Hartelijk bedankt.


1
2017-11-19 10:13


oorsprong


Als een antwoord nuttig is geweest, moet u dit accepteren (klik op het vinkje). Je kunt het ook overstemmen. - guntbert


antwoorden:


U krijgt deze fout omdat een repository zonder tekensleutel op uw systeem is toegevoegd aan uw apt repositorylijst. Ik denk dat deze repo is toegevoegd tijdens up-gradatie van dat pakket dat u noemde. Om te stoppen met het ontvangen van deze fout, hoef je alleen maar commentaar te geven of die repo te verwijderen apt repolijst. Om dit te doen, uitvoeren sudo apt-get update op terminal en kijk welke repo is gemarkeerd als niet-geverifieerd in de foutuitvoer. Deze repo is te vinden op één van de twee plaatsen, in /etc/apt/sources.list bestand of in bestanden gevonden in /etc/apt/sources.list.d/ directory. Het enige wat je hoeft te doen is die repo toevoegen # begin van de regel en de volgende keer dat u rent sudo apt-get update, hoogstwaarschijnlijk ontvang je deze fout niet.


1
2017-11-19 10:33



Heel erg bedankt, dit was erg handig en loste het probleem meteen op. - pinosan