Vraag ntpdate: geen server geschikt voor synchronisatie gevonden


Mijn klok staat uit, dus ik zou het willen synchroniseren met behulp van ntpdate. Ik heb verschillende NTP-servers geprobeerd, maar om de een of andere reden krijg ik altijd de volgende foutmelding:

$ sudo ntpdate ntp.ubuntu.com
4 Mar 12:27:35 ntpdate[1258]: no server suitable for synchronization found
$ sudo ntpdate pool.ntp.org
4 Mar 12:27:50 ntpdate[1267]: no server suitable for synchronization found
$ sudo ntpdate de.pool.ntp.org
4 Mar 12:28:01 ntpdate[1273]: no server suitable for synchronization found
$ sudo ntpdate us.pool.ntp.org
4 Mar 12:28:12 ntpdate[1276]: no server suitable for synchronization found

Gerelateerde Vragen

Ik heb doorgekeken Gerelateerde Vragen, maar geen oplossing voor mijn probleem:

Dingen die ik heb geprobeerd

Ik heb het ntp-pakket geïnstalleerd

... en geprobeerd met de ntpd daemon in plaats van de ntpdate nut. Het zal mijn tijd ook niet synchroniseren; de daemon begint goed, maar mijn klok blijft uit. Ik heb zelfs geprobeerd het exacte te gebruiken /etc/ntp.conf van het geaccepteerde antwoord in de laatste post en het herstarten van de daemon. Niet gaan. Hoe dan ook, ik wil de daemon niet gebruiken. Ik ben me er perfect van bewust ntpdate wordt beschouwd als "verouderd", en het wordt geadviseerd om te gebruiken ntpd -q in plaats daarvan. Zie ook hier:

Maar sinds ntpd werkt ook niet voor mij, het probleem ligt ergens anders. En ik merk dat ik liever geen extra pakketten hoef te installeren alleen voor het synchroniseren van de klok. ntpdate wordt vooraf geïnstalleerd met Ubuntu en het zou prima moeten werken. Dus heb ik de ntp pakket opnieuw.

Misschien is poort 123 geblokkeerd?

Van deze post:

... Ik kreeg het idee dat poort 123 mogelijk geblokkeerd is van mijn computer / netwerk op mijn werkplek. Inderdaad,

$ sudo nmap -p123 -sU -P0 localhost
...
PORT    STATE  SERVICE
123/udp closed ntp 
...
$ sudo ufw allow 123/udp
Rules updated
Rules updated (v6)
$ sudo nmap -p123 -sU -P0 localhost
...
PORT    STATE SERVICE
123/udp open  ntp
...

Maar nog steeds:

$ sudo ntpdate ntp.ubuntu.com
4 Mar 13:06:16 ntpdate[4361]: no server suitable for synchronization found

Zelfs met de -u optie, die vertelt ntpdate om een ​​niet-bevoorrechte poort te gebruiken voor synchronisatie (in plaats van poort 123) die zeker niet geblokkeerd is van mijn werkplek:

$ sudo ntpdate -u ntp.ubuntu.com
4 Mar 13:06:28 ntpdate[4427]: no server suitable for synchronization found

Misschien zijn de lagen te hoog?

Ten slotte, vanaf deze post bij serverfault:

... Ik dacht dat de lagen van de NTP-servers misschien te hoog zijn. Dat zijn ze echter niet. Laten we wat meer informatie voor foutopsporing bekijken:

$ sudo ntpdate -dv ntp.ubuntu.com
 4 Mar 13:12:24 ntpdate[4523]: ntpdate 4.2.6p5@1.2349-o Wed Oct  9 19:08:07 UTC 2013 (1)
Looking for host ntp.ubuntu.com and service ntp
host found : golem.canonical.com
transmit(91.189.89.199)
transmit(91.189.94.4)
transmit(91.189.89.199)
transmit(91.189.94.4)
transmit(91.189.89.199)
transmit(91.189.94.4)
transmit(91.189.89.199)
transmit(91.189.94.4)
transmit(91.189.89.199)
transmit(91.189.94.4)
91.189.89.199: Server dropped: no data
91.189.94.4: Server dropped: no data
server 91.189.89.199, port 123
stratum 0, precision 0, leap 00, trust 000
refid [91.189.89.199], delay 0.00000, dispersion 64.00000
transmitted 4, in filter 4
reference time:    00000000.00000000  Mon, Jan  1 1900  1:00:00.000
originate timestamp: 00000000.00000000  Mon, Jan  1 1900  1:00:00.000
transmit timestamp:  d6c041ae.e6166441  Tue, Mar  4 2014 13:12:30.898
filter delay:  0.00000  0.00000  0.00000  0.00000 
         0.00000  0.00000  0.00000  0.00000 
filter offset: 0.000000 0.000000 0.000000 0.000000
         0.000000 0.000000 0.000000 0.000000
delay 0.00000, dispersion 64.00000
offset 0.000000

server 91.189.94.4, port 123
stratum 0, precision 0, leap 00, trust 000
refid [91.189.94.4], delay 0.00000, dispersion 64.00000
transmitted 4, in filter 4
reference time:    00000000.00000000  Mon, Jan  1 1900  1:00:00.000
originate timestamp: 00000000.00000000  Mon, Jan  1 1900  1:00:00.000
transmit timestamp:  d6c041af.1948fc50  Tue, Mar  4 2014 13:12:31.098
filter delay:  0.00000  0.00000  0.00000  0.00000 
         0.00000  0.00000  0.00000  0.00000 
filter offset: 0.000000 0.000000 0.000000 0.000000
         0.000000 0.000000 0.000000 0.000000
delay 0.00000, dispersion 64.00000
offset 0.000000

 4 Mar 13:12:33 ntpdate[4523]: no server suitable for synchronization found

Pfeeewww ... dit was een lange tijd, sorry daarvoor. Ik heb geen idee. Enige aanwijzingen?

Update: extra informatie

Het maakt niet uit of een NTP-server HOSTNAME cijfers in /etc/ntp.confen ongeacht of het ntpd service draait of niet, elke keer als ik wegloop sudo ntpdate -u HOSTNAME, Ik krijg no server suitable for synchronization found. Hetzelfde als wanneer ntpd service is niet hardlopen en ik weglaten de -u keuze. Wanneer de ntpd service is hardlopen en ik laat het weg -u optie, ik krijg in plaats daarvan the NTP socket is in use, exiting.

Ook:

$ timedatectl status
      Local time: Wed 2014-03-05 13:11:54 CET
  Universal time: Wed 2014-03-05 12:11:54 UTC
        Timezone: Europe/Berlin (CET, +0100)
     NTP enabled: yes
NTP synchronized: yes
 RTC in local TZ: no
      DST active: no
 Last DST change: DST ended at
                  Sun 2013-10-27 02:59:59 CEST
                  Sun 2013-10-27 02:00:00 CET
 Next DST change: DST begins (the clock jumps one hour forward) at
                  Sun 2014-03-30 01:59:59 CET
                  Sun 2014-03-30 03:00:00 CEST

Maar de UTC-tijd is hier niet correct. Op dit moment is UTC tijd 11:11, niet 12:11.

En:

$ sudo hwclock --show
Wed 05 Mar 2014 01:11:56 PM CET  -0.625627 seconds

69
2018-03-04 11:38


oorsprong


je zei dat je `sudo ntpdate ntp.ubuntu.com` uitvoerde maar deed je dat na het toevoegen ntp.ubuntu.com naar /etc/ntp.conf s serverveld? Zie het volgende antwoord niet - Stormvirux
probeer `sudo ntpdate 0.ubuntu.pool.ntp.org - Stormvirux
Hallo, zie mijn opmerking bij uw antwoord. Ik heb geprobeerd toe te voegen server pool.ntp.org naar /etc/ntp.conf, maar ntpdate -u pool.ntp.org gooit dezelfde fout. Ik heb dit ook geprobeerd met ntp.ubuntu.com (toevoegen aan /etc/ntp.conf, opnieuw starten van de ntp service, re-running ntpdate -u op de exacte server waaraan ik zojuist heb toegevoegd /etc/ntp.conf). Opsommen, het maakt niet uit of de server waarmee ik probeer te synchroniseren wordt vermeld in /etc/ntp.conf. Ik krijg de no server suitable... fout in alle gevallen (behalve wanneer de ntp service is actief en Ik laat het weg -u optie, dan krijg ik de NTP socket in use fout). - Malte Skoruppa
Ok, ik heb het ook geprobeerd sudo ntpdate 0.ubuntu.pool.ntp.org, wat al in de /etc/ntp.conf het dossier. Geen geluk - dezelfde fout. - Malte Skoruppa


antwoorden:


Uw hostingprovider blokkeert ntp-pakketten. Deze hardhandige aanpak is door sommige ISP's geïmplementeerd als reactie op de DDoS-aanvallen. Je kunt zien dat ntpdate de pakketten fron the ntpdate -vd verzendt:

transmit(91.189.94.4)
transmit(91.189.89.199)
transmit(91.189.94.4)
transmit(91.189.89.199)

Ik neem contact op met uw internetprovider en vraag of deze externe ntp-aanvragen blokkeren en of ze een lokale server hebben die u kunt gebruiken voor tijdsynchronisatie.

Er zijn een paar meer duistere mogelijkheden, maar het is moeilijk om ze uit te sluiten omdat je geen logs van syslog hebt gepost.


44
2018-03-04 23:18



Je hebt volkomen gelijk. Het lijkt erop dat onze universiteit externe NTP-verzoeken blokkeert. Het biedt ook een paar lokale NTP-servers als alternatief. Deze werken perfect. Ik zie nu dat de uitvoer van ntpdate -dv zou ook enkele moeten bevatten receive(...) en niet alleen transmit(...) berichten. ;) Erg bedankt! - Malte Skoruppa
Een vraag echter, hoe kan de universiteit NTP-pakketten blokkeren wanneer ik die gebruik ntpdate met de -u keuze? Aangezien dit een niet-bevoorrechte poort gebruikt in plaats van poort 123, betekent dit dat hun firewallregels complexer moeten zijn dan eenvoudigweg "inkomende pakketten op poort 123 blokkeren". Dus doen ze een soort van diepe pakketinspectie dan? - Malte Skoruppa
Ze zullen één firewallregel hebben die zegt "Blokkeer alle verkeer met een bestemmingspoort van 123" en vervolgens een paar uitzonderingen voor hun ntp-hosts - dfc
Ik had hetzelfde probleem. Ik kon het oplossen door een traceroute uit te voeren en ik vond een lokale server op de route die ik kon synchroniseren met die waarop ntp werd uitgevoerd. Een van hen blokkeerde het echter. Bedankt voor de tips! - jonespm
Voor mij, ntpdate -vd zegt no servers can be used, exiting. - highBandWidth


Dit is echter geen ntp-antwoord, ...

sudo date -s "$(wget -qSO- --max-redirect=0 google.com 2>&1 | grep Date: | cut -d' ' -f5-8)Z"

deze en de krulversie hier.


27
2017-08-02 02:17



Dit is verschrikkelijk, maar het werkt. - Alan Plum
Onbewapende data naar bash-commando voeren als root? Geweldig bedankt voor het spelen. Dit antwoord moet worden ondergewaardeerd met extreme vooroordelen. - dfc
Veel minder pijnlijk dan het hebben van ISP-ondersteuning. Ook helemaal niet kritisch indien uitgevoerd in een lokale VM voor testdoeleinden. - Yalok Iy
Kun je me uitleggen wat het aan het doen is? - Suraj Jain
@SurajJain Veel webservers keren terug Date header. In die opdrachtdatum - s voor ingestelde datum, wget - S voor alle headers opslaan, 2> & 1 voor fouten bij het loggen in stdout, grep voor keuzelijn met header Date, knippen voor strip dag van de week en GMT. Z aan het einde voor behandelingsdatum als UTC. De nauwkeurigheid hangt af van de netwerksnelheid. - user1516873


Ik had hetzelfde probleem en dit is hoe ik het heb opgelost. Ik heb van boven tot onder een gedetailleerd antwoord gegeven. Misschien wilt u doorgaan naar het midden van mijn antwoord of gewoon de onderstaande schermafbeeldingen raadplegen om het in een oogopslag te begrijpen.

Eerste installeer ntpdate (dit heb je klaarblijkelijk gedaan)

sudo apt-get install ntpdate

NEXT U moet ntp met servers als volgt configureren:

Je moet op zijn minst de volgende parameter instellen in het /etc/ntp.conf configuratiebestand: server 

Open bijvoorbeeld het bestand /etc/ntp.conf met de nano-teksteditor:

sudo nano /etc/ntp.conf

Lokaliseer de serverparameter en stel deze als volgt in:

server pool.ntp.org

Maar meestal zijn in Ubuntu al enkele servers vooraf geschreven die dat misschien wel zijn

server 0.ubuntu.pool.ntp.org
server 1.ubuntu.pool.ntp.org
server 2.ubuntu.pool.ntp.org
server 3.ubuntu.pool.ntp.org

enter image description here

Sla vervolgens het bestand op en start de ntpd-service opnieuw:

sudo /etc/init.d/ntpd start

U kunt de systeemklok onmiddellijk synchroniseren met een NTP-server met de volgende opdracht:

sudo ntpdate pool.ntp.org

of gewoon uitvoeren al servers zijn gedefinieerd

sudo ntpdate 0.ubuntu.pool.ntp.org

of andere servers die zijn gedefinieerd met behulp van de server

over het algemeen

sudo ntpdate <one of the servername in /etc/ntp.conf>

MAAR daarna is er een kans dat je de fout krijgt NTP socket in use zoals hieronder getoond:

enter image description here

In dat geval gewoon hardlopen

ntpdate -u pool.ntp.org 

bijwerken wanneer ntp deamon wordt uitgevoerd

OF stop de deamon, update hem en start hem opnieuw als volgt:

sudo ntpdate pool.ntp.org
sudo service ntp stop
sudo ntpdate pool.ntp.org
sudo service ntp start

en je zult krijgen

enter image description here


9
2018-03-04 13:43



Hallo, bedankt voor je gedetailleerde antwoord! Helaas werkte het niet voor mij. ik heb de /etc/ntp.conf dat kwam samen met Ubuntu, veranderde er nooit iets aan. Ik heb het hier geplakt: pastebin.com/bB0sskzv. ik ook geprobeerd toe te voegen server pool.ntp.org bovenaan de serverlijst, zoals te zien in screenshot. Vind dat hier: pastebin.com/YH372Jdi. Met deze beide instellingen, Heb ik de reeks opdrachten uitgevoerd die u hebt voorgesteld: ik heb een schermafbeelding toegevoegd aan mijn oorspronkelijke bericht. Het resultaat was precies hetzelfde met zowel het ongewijzigde als het gewijzigde /etc/ntp.conf. Nog andere ideeën? Bedankt! - Malte Skoruppa
wat doet timedatectl status terugkeer - Stormvirux
Zie output van de timedatectl status commando in mijn originele bericht. - Malte Skoruppa
Ik heb nu geprobeerd met alle 4 vooraf gedefinieerde servers (namelijk, {0..3}.ubuntu.pool.ntp.org), zowel met als zonder -u keuze. Altijd dezelfde fout. - Malte Skoruppa
Vertel me deze ook. output van sudo hwclock --show - Stormvirux


Gebruik htpdate

Als ntp-transmissie in uw netwerk is geblokkeerd, installeer dan htpdate. Het synchroniseert de tijd via het http-protocol. De nauwkeurigheid zal 0,5 seconden bedragen, volgens de man-pagina.

sudo apt-get install htpdate
sudo htpdate -a google.com

htpdate-service start wanneer u het pakket installeert. De tijd zal onmiddellijk worden bijgewerkt als er een internetverbinding is.


3
2017-08-21 10:22



Kopieer en plak niet hetzelfde antwoord in elk onderwerp dat u over ntp vindt. - sempaiscuba


Gelijkaardig aan Alex's antwoord, dit werkte voor mij om de ntp poort te omzeilen die firewalled was:

sudo date -s "$(curl http://s3.amazonaws.com -v 2>&1 | \
  grep "Date: " | awk '{ print $3 " " $5 " " $4 " " $7 " " $6 " GMT"}')"

2
2018-02-23 01:45





Zelfs wij werden geconfronteerd met deze kwestie ... Maar we zijn erin geslaagd om het op te lossen door op dit commando te klikken:

ssh localhost "sudo apt-get install ntp ntpdate ; sudo service ntp stop; sudo ntpdate 0.ubuntu.pool.ntp.org; sudo service ntp start"

Hiervoor moet je installeren openssh-server.

Verwijder ook ntp en ntpdate (sudo apt-get remove --purge ntp ntpdate) voordat het bovenstaande wordt geactiveerd ssh opdracht.


0
2018-03-23 10:05



ssh demon installeren om ... zichzelf te sshennen? - Massimo


Gewoon een suggestie. Ik had dit probleem al enige tijd, toen begon het te werken, maar ik kwam erachter dat dat zo is geen plaats meer op de schijf. 


0
2017-07-20 19:30