Vraag Hoe schakel ik venster verplaatsen met alt + linkermuisknop in GNOME Shell uit?


Er zijn veel van posts hierover over Unity, dit gaat over kabouter.

Net als bij andere posters, gebruik ik apps (met name Inkscape) die gebruikmaken van Alt-Click en Alt-drag. Gnome-shell haalt dit van me af en daarmee functies in de toepassing uitschakelend.

Ik heb geprobeerd

  • met behulp van de Move-invoegtoepassing van ccsm - u kunt dit uitschakelen en het venster met Alt-slepen wordt nog steeds weergegeven.

  • met behulp van gconf-editor om te veranderen / apps / metacity / general / mouse_button_modifier - dit heeft geen effect AFAICS.

Het hindert me echt. Anders vind ik gnome-shell een echt productieve omgeving.


69
2018-04-02 11:02


oorsprong


Mogelijk duplicaat van Hoe venster verplaatsen met alt + linker muisknop uit te schakelen? - hellocatfood
Ik wil erop wijzen dat het niet GNOME is om dit te doen, maar eerder Ubuntu. De standaardwaarde voor GNOME Shell is om te hebben <Super> de vensterwijzigingscode zijn. - Daniel Quinn
@DanielQuinn Inderdaad. Gearchiveerd bugs.launchpad.net/ubuntu/+source/mutter/+bug/1704580 om Ubuntu te vragen het terug te schakelen naar de Super / Windows-toets. - Mikel


antwoorden:


Allereerst installeer dconf-gereedschappen  Install dconf-tools.

Voer hiervoor de volgende opdracht uit:

sudo apt-get install dconf-tools

Open het dan, alt+F2 → dconf-editor.

Blader naar beneden naar org → gnome → desktop → wm → preferences → mouse-button-modifier → Stel deze in op welke toets u maar wilt.

enter image description here


Of, equivalent,

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier "<Super>"

in de terminal. (Dit vereist geen van beide dconf-editor, ook niet dconf-gereedschappen  Install dconf-tools)

Waarschuwing: Als u het op niets zet, betekent dit dat alle klikken vensters verplaatsen, in plaats van het uit te schakelen!


103
2018-04-02 12:34



Waarschuwing! Niets doen betekent dat alle klikken bewegen vensters, in plaats van het uit te schakelen! - Andrea
Ik heb de methode dconf-editor geprobeerd, maar er lijkt niets te zijn gebeurd. <ALT> is nog steeds mijn modificatietoets. Ik heb geprobeerd "['<Control> <Alt>']" (volgens de syntaxis van de sneltoetsopties) en "<Control> <Alt>". Moet ik opnieuw opstarten om dit effect te geven? - Gordon Bean
Ik heb het eerst geprobeerd met de gsettings commando, en het lijkt het succesvol te hebben veranderd, maar Alt + Drag zou nog steeds het venster verplaatsen. Zelfs na een herstart. Ik heb toen geïnstalleerd dconf-gereedschappen en bevestigd met de dconf-editor dat mouse-button-modifier inderdaad was veranderd, maar zoals ik al zei, Alt + Drag verplaatst nog steeds vensters. (Ik ben op Mint Cinnamon 17.2 64bit) - Bloke
"<Alt> + <Super>" waarde werkt best goed voor mij - vp_arth
@Bloke: ik denk erover Kaneel, het zou moeten zijn org.cinnamon.desktop.wm.preferences in plaats daarvan. Dat werkte tenminste voor mij. - Giraldi


Ga als volgt te werk om het sleepslepen probleem met Alt + klikken verplaatsen:

sudo gconftool-2 --set /org/gnome/desktop/wm/preferences/mouse-button-modifier --type string '<Super>'

Doet hetzelfde, echt, alleen met een andere configuratie-tool en minder jacht-en-klik.

Gebruik voor nieuwere versies die dconf / gsettings gebruiken dit:

gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier "<Super>"

8
2018-05-18 18:03



gsettings set org.gnome.desktop.wm.preferences mouse-button-modifier "<Super>" voor dconf. - ulidtko


Gebruik de Tweak Tool (gnome-tweak-tool):

Windows> Windows Action Key


7
2018-02-20 23:34



Dank je! Dit werkte voor mij toen alles met dconf-editor of de commandoregel of compilatie mislukte. Nu kan ik alt gebruiken voor andere snelkoppelingen en de functionaliteit van verschillende programma's herstellen. - Silvestris


Ik ging zitten alt+Super als een tijdelijke oplossing. Dus ik kan de gebruiken alt sleutel in Inkscape en Super voor activiteiten.


6
2018-04-19 01:34



wat bedoel je met "activiteiten"? ik ben veranderd Alt naar Super en het werkt goed voor mij. Ik merkte geen bijwerkingen. Waarom zou je nodig hebben? Alt + Super? - faizal
wiki.gnome.org/Projects/GnomeShell/Tour#Activities_Overview  Als u "Super" instelt voor het verplaatsen van vensters, kunt u dit niet gebruiken voor "Activiteitenoverzicht". Kijk naar het plaatsen van tijd, het was twee jaar geleden. - KEIII
Twee jaar is niets. - Johan Boulé


In UBUNTU 14.04 wordt LTS gebruikt in dconf-syntaxis zoals

<Alt><Super>

Werkt goed voor mij.

BTW: als je iets verkeerd hebt ingesteld, begint het venster te verplaatsen bij elke klik. Gebruik om naar de knop "Instellen naar standaard" te gaan. En sloeg.

enter image description here


3
2018-03-31 08:05





In Mint kan dit worden gewijzigd of uitgeschakeld in system settings > windows > behavior > 'Special key to move and resize window'


2
2018-01-29 11:11





  1. Ga naar Systeeminstellingen
  2. Selecteer toetsenbord
  3. Klik onderaan links op 'Layout-instellingen'
  4. Selecteer uw taal en klik op de knop 'Opties' rechtsonder
  5. Selecteer 'Alt / Win sleutelgedrag'
  6. Verander het naar degene die je leuk vindt. Ik gebruik 'Left Alt is geruild met Left Win'.

1
2018-03-25 16:32