Vraag Hoe krijg je xfce4-power-manager om te werken in Lubuntu 14.04?


Ik heb alleen maar problemen gehad. Tijdens de installatie ging alles goed, maar ik kon de actie van het deksel niet wijzigen en het ophangen was erg buggy - soms werkte het, soms niet.

Toen ontdekte ik dat xfce4-power-manager 1.4.1 lost het probleem met het laptopdeksel op, dus ik heb een deb gedownload en het geïnstalleerd. Op de eerste run ging het mooi, maar bij herstarten werkt het helemaal niet. Er worden 2 instanties gestart bij het opstarten, soms wordt zelfs weergegeven dat opschorten niet beschikbaar is en werken deksels en stroomacties niet helemaal niet.

Helpen?


1
2017-10-05 09:21


oorsprong




antwoorden:


Als je Lubuntu echt moet gebruiken in plaats van je standaardsessie te wijzigen in XFCE (Xubuntu) dit is de link u zou moeten bezoeken om een ​​aantal oplossingen te vinden voor uw probleem, die van invloed zijn op vele andere gebruikers, behalve uzelf. Hoewel je op het eerste gezicht denkt dat de post een aantal bugs specifiek voor Lubuntu 13.10 behandelt, lees dan verder op die pagina om erachter te komen dat dezelfde bug ook van toepassing is op Lubuntu 14.04.

Dit is de reden waarom ik je heb aangespoord om de xfce-sessie te gebruiken in plaats van de lxde-sessie, wat misschien goed is voor desktopcomputers, maar het is niet zo goed voor laptops.

Om volledige functies van xfce4-power-manager in Lubuntu te kunnen gebruiken, moet en citeer ik vanaf die pagina:

  1. U kunt naar ---> Menu> Voorkeuren> standaardtoepassing voor LXsession> Power Manager> Overig> xfce4-power-manager> Toepassen> gaan   Reboot.

WEL EENS, houd er rekening mee dat dit niet genoeg is en deze functie zou moeten   standaard geladen zijn, net zoals het vroeger was.

  1. Een andere oplossing is om Preferences -> Default applications for LXSession te openen, ga dan naar het tabblad autostart en verander hier de optie   "Autostarted applicaties uitschakelen" van de standaard "config-only" in   "Nee". Mogelijk moet u de instellingen voor de laptopmodus wijzigen van "nee" in   "Ja". (tabblad instellingen).

Merk op dat u het "netwerk" van Prefereces -> Desktop moet uitschakelen   Sessie-instellingen of je zult tegelijkertijd twee nm-applets laten draaien   tijd.

Er zijn andere onofficiële workarounds ontworpen voor xfce power manager om te werken in Lubuntu, en je kunt ook de antwoorden controleren om een ​​andere goede link te vinden naar deze pagina waar je nog een andere 'werkoplossing' voor je probleem kunt vinden:

  1. Ik had dit probleem, ik verwijderde "Power Manager" uit de lijst "Application Autostart" in Instellingen -> Sessie en opstarten en nog een   toepassing met dit commando xfce4-power-manager --no-daemon dan i   heb dit probleem nog niet.

2
2017-10-05 09:39



Ik doe niet wil dat doen. Trouwens, xfce4-power-manager is geïnstalleerd door standaard in Lubuntu 14.04. - Juraj Fiala
Dan zou u Synaptic Package Manager moeten openen, en gebruiken voor sleutelwoord in het zoekveld deze: lxde . Kijk in de lijst met resultaten specifiek voor LXDE-pakketten en andere aan LXDE gerelateerde pakketten, vooral die met betrekking tot energiebeheer. Het is absoluut noodzakelijk dat u installeert lxdedie in Lubuntu niet standaard is geïnstalleerd om je systeem een ​​beetje stabieler te maken. Vergeet niet de overige lxde-gerelateerde pakketten die nuttig kunnen blijken te zijn voor laptopgebruikers. - Taz D.
Taz - dit is hoe je Xfce (Xubuntu) moet gebruiken, niet hoe je xfce4-power-manager moet gebruiken in LXDE (Lubuntu) ... - Wilf
Bedoel je dat het installeren van lxde en andere lxde gerelateerde pakketten niet goed is voor Lubuntu? Ik veronderstel dat je mijn geposte antwoord op zijn vraag bedoelt (het installeren van xubuntu-desktop), maar ik ben van plan die te verwijderen zodra hij die lxde-pakketten daadwerkelijk installeert en zegt dat hij blij is met energiebeheer. Hoe dan ook, waarom moet Lubuntu xfce4-power-manager gebruiken en niet een of ander native power manager-pakket voor LXDE? - Taz D.
Nummer 1) zet me op de goede weg. Op Lubuntu 15.04 werkte het voor mij: Menu> Voorkeuren> standaardtoepassing voor LXsession> Core-toepassingen: instellen zowel "Power Manager" als "Lock Screen Manager" naar "xfce4-power-manager - drodsou