Vraag Kan ik Kali-tools op Ubuntu installeren?


Ik wil weten of er een manier is om Kali-tools te installeren zoals sqlmap, nikto, john, aircrack-ng, ... op Ubuntu 12.04?

Zo ja, hoe moet ik dan verder gaan?


11
2017-12-10 04:52


oorsprong


Ja, ze bevinden zich allemaal in de debian-repositories, die beide distro's (grotendeels) delen. Anders kun je een .deb downloaden en gebruiken dpkg -i - No Time
Kan iemand deze vraag bijwerken met een nieuw antwoord met actuele repositories? Dank je! - Byte Commander
@Adnan Ali Fout bij 'onbekende pantserkop' misschien wat lege ruimte aan het begin van versie: SKS 1.1.4, verwijder ze gewoon - Zhaosheng Qiu


antwoorden:


De enige huidige versie van Ubuntu waar dit voor werkt is 12.04 en de repo's zijn sinds 2013 niet meer bijgewerkt. Gebruik het niet.

Zie voor 14.04+ het tweede antwoord.


Kopieer de volgende Kali-repositories:

deb http://ppa.launchpad.net/wagungs/kali-linux2/ubuntu YOUR_UBUNTU_VERSION main 
deb-src http://ppa.launchpad.net/wagungs/kali-linux2/ubuntu YOUR_UBUNTU_VERSION         main 
deb http://ppa.launchpad.net/wagungs/kali-linux/ubuntu YOUR_UBUNTU_VERSION main 
deb-src http://ppa.launchpad.net/wagungs/kali-linux/ubuntu YOUR_UBUNTU_VERSION main 

Vervang de tekst YOUR_UBUNTU_VERSION op basis van uw Ubuntu-versie.

  • Ubuntu 12.04: precise
  • Ubuntu 12.10: quantal
  • Ubuntu 13.04: raring

Ervan uitgaande dat u Ubuntu 13.04 gebruikt, zouden uw repositories dat zijn

deb http://ppa.launchpad.net/wagungs/kali-linux2/ubuntu raring main
deb-src http://ppa.launchpad.net/wagungs/kali-linux2/ubuntu raring main
deb http://ppa.launchpad.net/wagungs/kali-linux/ubuntu raring main
deb-src http://ppa.launchpad.net/wagungs/kali-linux/ubuntu raring main 

Opmerking: als u een Ubuntu 14.04-gebruiker bent, kunt u gebruiken raring, omdat de Trusty-versie van Kali-bibliotheken niet wordt vrijgegeven

Update bronnen

Open uw bronnen met behulp van de opdracht

sudo -H gedit /etc/apt/sources.list.d/kali-tools.list

Nu zal de gedit-editor het bestand openen kali-tools.list. Plak de bovenstaande code aan het einde van uw bestand en bewaar.

Kopieer de PGP-sleutel

Kopieer de onderstaande sleutel en sla deze op als key.pgp-tekstbestand op uw bureaublad.

-----BEGIN PGP PUBLIC KEY BLOCK-----
 Version: SKS 1.1.4
 Comment: Hostname: keyserver.ubuntu.com

 mI0ET324YwEEANbSlISrOlAGjxgFRxiN6jk0JIl/vxQ8lapRdxZ4DHDAQdXbX4AuigMBkP5e
 sOxhMpDnkgMRtEVpaBMdQheA0/431pPQYqkr3jdeZw5JS5opiyJ4qr/QrcoSFHSluEkWkbZ6
 RYOkA25vW31KK2FB2LQVRYk580llXAVgIUznm2ATABEBAAG0GExhdW5jaHBhZCBQUEEgZm9y
 IHdhZ3VuZ4i4BBMBAgAiBQJPfbhjAhsDBgsJCAcDAgYVCAIJCgsEFgIDAQIeAQIXgAAKCRAb
 IuuNj9/bVxabBADSGN8cp+hqkdZqwq263wdz/UGsiuB1bCrH06/HznC/ZC5rjfH3aQ1Dwwag
 zYCrSD3c0cKNAqD10009N76RMlzZBH8kKL9khH3zPL/k4/lYuVP7y6NKFbBsnawEUc0mWcCa
 mH4ScTdWWPXP/mOQiUUjnQ1bZhzpcbQOb+hEUAqExg==
 =fJ+8
 -----END PGP PUBLIC KEY BLOCK-----

PGP-sleutel toevoegen in apt

Open terminal en type

cd Desktop
sudo apt-key add key.pgp

Als uw belangrijkste toevoeging succesvol is, zult u zien Ok.

Werk nu uw apt-get-repository bij met behulp van de opdracht

sudo apt-get update

Installeer Synaptic Package Manager

Gebruik de opdracht

sudo apt-get install synaptic

Als u al Synaptic hebt geïnstalleerd, kunt u deze stap overslaan.

Kali Tools installeren

Open nu de Synaptic Package-manager en klik op Origin. U kunt 2 Kali-bibliotheken op naam bekijken

LP-PPA-wagungs-kali-linux/raring
LP-PPA-wagungs-kali-linux2/raring

Klik op de repository's en installeer de Tools uit de lijst.

screenshot


14
2017-12-10 06:57



Hoe zit het met Utopic (14.10) en Vivid (15.04)? Gebruikt u nog steeds de Raring-repo? Of bestaan ​​ze? - Byte Commander
@ByteCommander: Na snel inchecken ppa.launchpad.net/wagungs/kali-linux2/ubuntu, het antwoord is nee, ze bestaan ​​niet. Enkel en alleen raring beschikbaar. - Toan Nguyen
@NNToan Kun je zien of ze bruikbaar zijn voor de huidige Ubuntu-versies of moet je niet eens proberen die lang verouderde versies te gebruiken? Ik vermoed dat ze dan twee jaar updates missen en zijn behoorlijk verouderd om vandaag te gebruiken. - Byte Commander
Het geeft Fout: gpg: onbekende pantser header: Versie: SKS 1.1.4 gpg: onbekende pantser header: Commentaar: Hostnaam: keyserver.ubuntu.com OK - Adnan Ali
Commentaar afkomstig van een NAA van Zhaosheng Qiu: @Adnan Ali Fout bij 'onbekende pantserkop' misschien wat lege ruimte aan het begin van versie: SKS 1.1.4, verwijder ze gewoon - bummi


Ubuntu heeft meer dan dat denk ik!

  • Cyber ​​Sec I PPa's (Cybersec Team)

  • Black hat sec PPA's (door D4RkNiK0l4s)

Utopic

ppa:darklordpaunik8880/kalibuntu
ppa:darklordpaunik8880/kalibuntu1

betrouwbaar

ppa:cybersec/chaos-ppa
ppa:cybersec/chaos-ppa-v1
ppa:cybersec/chaos-ppa-v2
ppa:cybersec/test
ppa:cybersec/trojan-horse
ppa:darklordpaunik8880/darkminttrustytahr
ppa:darklordpaunik8880/darkminttrustytahr2
ppa:darklordpaunik8880/darkminttrustytahr3
ppa:darklordpaunik8880/darkminttrustytahr4

In die PPa's zijn meer dan 500+ hacktools beschikbaar, deze man heeft het heel goed gedaan !! Die tools zijn allemaal open source en ze horen niet bij een naam of iets anders. : D Ubuntu is een geweldige distributie en het heeft vele, vele tools en pakketten beschikbaar via repository installeer ze als volgt:

betrouwbaar

sudo add-apt-repository  ppa:cybersec/chaos-ppa
sudo add-apt-repository  ppa:cybersec/chaos-ppa-v1
sudo add-apt-repository  ppa:cybersec/chaos-ppa-v2
sudo add-apt-repository  ppa:cybersec/test
sudo add-apt-repository  ppa:cybersec/trojan-horse
sudo add-apt-repository  ppa:darklordpaunik8880/darkminttrustytahr
sudo add-apt-repository  ppa:darklordpaunik8880/darkminttrustytahr2
sudo add-apt-repository  ppa:darklordpaunik8880/darkminttrustytahr3
sudo add-apt-repository  ppa:darklordpaunik8880/darkminttrustytahr4 

Utopic

 sudo add-apt-repository ppa:darklordpaunik8880/kalibuntu                  
 sudo add-apt-repository ppa:darklordpaunik8880/kalibuntu1

Open vervolgens de synaptic of wat je maar wilt gebruiken en begin met het installeren van je tools !!


8
2017-07-28 15:13





ten eerste raad ik je niet aan om iets in de sources.list te veranderen, omdat het je ubuntu vroeg of laat zal beschadigen.

maar er is een goede manier om dit te doen in deze instructies: er is een goede tool genaamd katoolin die tijd voor je zal sparen.

waarschuwing: maak een kopie van uw bronnenlijst

stap 1: kopieer uw originele sources.list

sudo cp /etc/apt/sources.list /etc/apt/sources.list.original

stap 2: installeer git

sudo apt-get install git

stap 3: verkrijg een katoolin-tool

git clone https://github.com/LionSec/katoolin.git

stap 4: kopieer het hulpmiddel naar uw usr bin-map

cp katoolin/katoolin.py /usr/bin/katoolin

stap 5: wijzig machtigingen voor het hulpprogramma

sudo chmod +x /usr/bin/katoolin

stap 6: voer de tool uit en extra voorzichtig om een ​​sources.list op te ruimen na elke keer dat je er een tool uit installeert of gebruik de tool om de repos te verwijderen, en controleer jezelf zelf.

sudo katoolin

opruimen na het uitvoeren van de tool

waarschuwing: gebruik geen apt-get-upgrade na het uitvoeren van de tool, het zal je systeem en gnome verpletteren


0
2017-09-16 11:00



kun je niet gewoon terugkeren naar de lijst met back-upbronnen? - Aymon Fournier