Vraag Problemen met hardlopen: apt-get -o Acquire :: ForceIPv4 = true


Ik heb de aanbevelingen gevolgd om IPv4 te forceren, maar in mijn geval werkt het niet.

Dat is wat ik krijg:

> sudo apt-get -o Acquire::ForceIPv4=true update
0% [Conectando a dl.google.com (64.233.190.91)] [Conectando a packages.linuxmint.com (68.235.39.11)] [Conectando a archive.ubuntu.com (91.189.88.149)] 

En er gebeurt niets anders.

Ik heb ook de wijzigingen toegepast die worden genoemd in Dit artikel zonder resultaten:


1
2017-09-05 15:06


oorsprong


Is uw verbinding niet onder een proxy? - Redbob
Ja, mijn verbinding is onder een proxy. - Dario
U moet de proxy-verbindingen bijwerken in uw /etc/apt/apt.conf. Je zou dit kunnen doen door te bellen network app bij Unity launcher en zet het daar op Handmatig en vul velden. Systeembreed toepassen en proberen sudo apt-getnog een keer. - Redbob


antwoorden:


Als u proxy-verbindingen met uw computer wilt inschakelen, moet u deze bewerken /etc/apt/apt.conf.

Er zijn twee manieren om dit te doen:

1. Eenheid: Lancering netwerk app bij Unity launcher, volg zoals de afbeelding laat zien:

enter image description here

2. Terminal

Bewerk /etc/apt/apt.conf, het toevoegen van deze regels (IP en poort zijn slechts voorbeelden):

Acquire::http::proxy "http://172.24.12.50:3128/";
Acquire::https::proxy "https://172.24.12.50:3128/";
Acquire::ftp::proxy "ftp://172.24.12.50:3128/";
Acquire::socks::proxy "socks://172.24.12.50:3128/";

Als deze proxy verificatie vereist, moet u IP-informatie wijzigen met user:password@ip:port. bijvoorbeeld hieronder:

Acquire::http::proxy "http://user:password@172.24.12.50:3128/";
Acquire::https::proxy "https://user:password@172.24.12.50:3128/";
Acquire::ftp::proxy "ftp://user:password@172.24.12.50:3128/";
Acquire::socks::proxy "socks://user:password@172.24.12.50:3128/";

Als uw netwerkproxy met Microsoft NTLM is geverifieerd, zoals ik hier heb, moet u een lokale proxy maken om deze te verhelpen. ik gebruik cntlm. Het bevindt zich in de Universe-repository.


2
2017-09-05 15:48



Bedankt voor je antwoord, maar ik heb mijn proxy al geconfigureerd. Ik heb zelfs een internetverbinding. Iets anders, ik gebruik Linux Mint 18.2 en er is geen apt.conf-bestand. In plaats daarvan heb ik een map etc / apt / apt.conf.d. - Dario
Maak een bestand met de naam 95proxy's in deze map met dezelfde inhoud. - Redbob
Opgelost! Hartelijk bedankt! - Dario