Vraag Pakketten uitsluiten van `apt-get-upgrade` [dupliceren]


Mogelijke duplicaten:
Hoe kan het updaten van een specifiek pakket worden voorkomen?
Bewaar de Ubuntu-pakketversie die ik nu gebruik 

Is het mogelijk om alle pakketten te upgraden, behalve een bepaald pakket? Is er zoiets als apt-get upgrade --exclude package_to_exclude?


75
2018-01-30 03:46


oorsprong


Eigenlijk kan je dit op verschillende manieren doen, zie de link die ik je hierboven heb gegeven. - Panther


antwoorden:


Om een ​​pakket te houden:

In het kort: sudo apt-mark hold <package>

of

echo <package> hold | sudo dpkg --set-selections

Om een ​​pakket te onthouden:

In het kort: sudo apt-mark unhold <package>

of

echo <package> install | sudo dpkg --set-selections

128
2018-01-30 04:11



Ik krijg de volgende foutmelding: Usage: apt-mark [options] {markauto|unmarkauto} packages... apt-mark: error: first argument must be 'markauto', 'unmarkauto' or 'showauto' - Olivier Lalonde
Vreemd. Het werkt voor mij. Gewoon geprobeerd met behulp van sudo apt-mark hold unity-greeter - Zoke
Ik denk dat deze fout te maken heeft met de Ubuntu-versie. Versies voor 12.04 bieden geen ondersteuning voor apt-mark hold - user733211
Zodra het pakket opnieuw moet worden bijgewerkt, gebruikt u de parameter unhold. - Markus Junginger
Ook, sudo apt-mark showhold zal laten zien dat hij nu in de wacht staat. (Opmerking: dat is het niet showhole, dat is een Netflix-foutstatus.) - flickerfly


Bekijk "Inleiding tot het houden van pakketten" in de Ubuntu's Vastzetten Howto


3
2018-01-30 04:00