Vraag Hoe maak je een alleen-lezen bestandssysteem schrijfbaar?


  1. Ik ben niet zeker sinds wanneer het bestandssysteem op mijn digitale audio speler is veranderd alleen lezen. Ik kan geen bestanden kopiëren naar het of verwijder bestanden erop.

    Zijn er enkele mogelijke redenen voor het bestandssysteem van de speler wijzigen de toestemming van zijn bestandssysteem?

  2. Ik heb chmod geprobeerd:

    $ sudo chmod a+rw SGTL\ MSCN/ 
    chomd: changing permissions of `SGTL MSCN/': Read-only file system
    

    waar "SGTL MSCN" is aangekoppeld punt van de digitale audiospeler.

    Ik vroeg me af hoe ik het moest maken beschrijfbaar?

Bedankt en groeten!


75
2018-06-07 19:58


oorsprong


Bedankt! Ik heb dat al geprobeerd, en dezelfde output. Ik zal dit aan mijn bericht toevoegen. - Tim
Zou je ook het merk van de speler kunnen toevoegen? :) zoeken op 'SGTL MSN' brengt eigenlijk ALLEEN dit onderwerp ter sprake: D Als je echt pech hebt, is het het apparaat dat wordt afgeluisterd: als laatste (!) resort reset je de speler. Maar alleen als je niet snel goede antwoorden krijgt (ish) :) - Rinzwind
Mijn fout. De naam is "SGTL MSCN". - Tim
wat zijn de mount-opties mount| grep SGTL  ? - Emmanuel
Alles geprobeerd, en een eenvoudige oplossing gevonden (ketter). Sluit de usb aan op Windows 8 of 7, klik op "Repair External Drive", ga terug naar linux. Ik hoop dat dit iemand helpt. - alejoss


antwoorden:


Als een bestandssysteem read-only is gemount, chmod zal niet werken omdat het ook een schrijfbewerking is.

Probeer het opnieuw te lezen en te schrijven:

sudo mount -o remount,rw '/media/SGTL MSCN'

Als het apparaat een schrijfvergrendeling heeft (zoals SD-geheugenkaarten), moet u het uitschakelen. Hardware vergrendelingen kunnen niet worden uitgeschakeld door software. Merk op dat het schrijfslot op SD-geheugenkaarten zich bevindt bij het zicht dat je de letters ziet in de linkerbovenhoek en het ziet eruit als een heel kleine schakelaar.

Sommige bestandssysteemstuurprogramma's ondersteunen ook geen schrijfbewerkingen, dit is het geval met de oudere NTFS-module die door Linux wordt ondersteund. Gebruik voor NTFS-bestandssystemen de ntfs-3g stuurprogramma dat tegenwoordig automatisch moet worden gepickt. Zo niet, dan kunt u de bestuurder dwingen met iets als:

sudo mount -t ntfs-3g -o uid=$(id -u) /dev/sdb1 /mnt/

(waar /dev/sdb1 moet worden vervangen door uw blokapparaat en /mnt/ voor je bestemming)


99
2018-06-07 20:28



Ik probeer dit en krijg "DRIVE not mounted of bad option". - JeanSibelius
@mattshepherd als je witruimte in de bestandsnaam hebt, moet je deze omgeven met aanhalingstekens. - Lekensteyn
Nee, geen spaties. Ik, eh, eindigde het in Windows. - JeanSibelius
@XavierStuvw Als lezen / schrijven beschermd betekent alleen lezen, ok. Anders zou je het kunnen proberen af ​​te vegen en opnieuw te gebruiken. De wipefs commando kan op een partitie worden gebruikt om ervoor te zorgen dat er geen bestandssysteem wordt herkend. Zien man wipefs (onderdeel van util-linux). - Lekensteyn
@JoshuaSalazar hoe heb je het gerepareerd? Misschien zou u een nieuwe vraag kunnen maken en dergelijke details kunnen opnemen, deze commentaarsectie wordt een beetje te groot. - Lekensteyn


Als de USB-stick is gemonteerd als alleen-lezen. Ga naar Schijfhulpprogramma en ontkoppel de schijf. Klik vervolgens op Check Filesystem als er geen problemen zijn om de schijf opnieuw te koppelen. Na het monteren van de schijf zou het goed moeten werken, althans dat is hoe ik dit probleem heb opgelost.


4
2017-12-02 11:12



Het klinkt alsof het niets doet, maar dit heeft het voor mij opgelost - Karthik T


Ik had dit probleem op verschillende USB-sticks. Elke keer dat ik naar een antwoord zocht en verschillende suggesties probeerde, waaronder het gebruik van Terminal om opdrachten uit te voeren, opnieuw formatteren op zowel Linux- als Windows-machines, enz. Alles zonder succes.

Het overkwam mij vandaag opnieuw, dus opnieuw ging ik kijken of ik een oplossing kon vinden. Ik heb de dingen hier geprobeerd, maar ze werkten niet.

Uit wanhoop ging ik opnieuw naar Schijfhulpprogramma. Ik heb de drive gedeactiveerd en klik vervolgens op "Format" op het partitiegedeelte, niet op het drive-gedeelte - USB had alleen de enkele partitie. Deze keer WERKTE HET !!!!. Toen ging ik naar het drive-gedeelte en opnieuw formatteerde de enkele partitie als een master-opstartschijf en aapte er een beetje meer mee weg.

Het resultaat is dat ik nu de drive opnieuw kan lezen en beschrijven.

Ik weet niet of ik deze keer gewoon geluk heb gehad of niet. Maar het werkt weer.


4
2017-07-07 21:38





Als het een vaste schijf is en geen verwijderbare schijf, kunt u de vermelding permanent toevoegen.

sudo vi /etc/fstab

Voeg een item toe in de volgende indeling:

<file-system> <mount-point> <type> <options> <dump> <pass>

En dan:

mount -a

1
2018-06-07 23:14





Voor NTFS-bestandssystemen kan dit probleem optreden wanneer het niet goed is gedeactiveerd (waarschijnlijk door onverwacht afsluiten van vensters). In dergelijke gevallen zijn de bestandssystemen gemarkeerd als vergrendeld.

U kunt ze correct monteren met behulp van de volgende opdracht na het vervangen /dev/sda3 met uw eigen apparaatnaam:

sudo ntfsfix /dev/sda3

1
2018-05-07 13:25