Vraag Vereist installatie van niet-vertrouwde pakketten?


Ik heb gisteren geprobeerd VLC Player te installeren en ik kreeg de Requires installation of untrusted packages fout. Ik zocht uren naar een oplossing voor dit probleem en kwam uiteindelijk met een suggestie die zei om servers te veranderen voor het downloaden van updates van. Ik deed dit en het gaf me een 404-fout toen ik op "Check" klikte in de Update Manager. Ik probeerde mijn server terug te schakelen naar de hoofdserver (en daarna nog een aantal andere), maar ik krijg nu nog steeds een 404-foutmelding: enter image description here

En de andere fout die ik krijg bij het downloaden of updaten: enter image description here

Bewerk: Output van cat /etc/apt/sources.list:

deb-src http://us.archive.ubuntu.com/ubuntu/ precise main restricted #Added by software-properties

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://us.archive.ubuntu.com/ubuntu/ precise main restricted multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise multiverse universe #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates main restricted multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-updates restricted main multiverse universe #Added by software-properties

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ precise universe
deb http://us.archive.ubuntu.com/ubuntu/ precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse #Added by software-properties

deb http://us.archive.ubuntu.com/ubuntu/ precise-security main restricted multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ precise-security restricted main multiverse universe #Added by software-properties
deb http://us.archive.ubuntu.com/ubuntu/ precise-security universe

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu precise partner
deb-src http://archive.canonical.com/ubuntu precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.

76
2017-09-04 21:19


oorsprong


plak de uitvoer cat /etc/apt/sources.list en dan gpg --list-keys plakken in plakken Ubuntu - twister_void
Ik heb mijn vraag bewerkt. - Isaiah Bugarin


antwoorden:


Op basis van de fouten die je hebt geplakt in het gedeelte Opmerkingen van mijn vorige antwoord, heb ik nog een andere mogelijke oplossing:

sudo apt-get clean
cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get clean 
sudo apt-get update

Hiermee wordt de cache opnieuw opgebouwd.
Courtesy:http://ubuntuforums.org/showthread.php?t=1983220#8


89
2017-09-08 06:43



DOE DIT NIET: nu heb ik gewoon Engels en ben ik al mijn andere talenpakketten kwijt - João Pimentel Ferreira
werkte voor mij ~ - Sam Nikzad


Deze link kan helpen. Het adresseert een zeer vergelijkbaar probleem.

Kortom, u opent een terminal en typt sudo apt-get update && sudo apt-get upgrade. Dat deed het voor mij.


33
2017-09-08 04:27





Het geaccepteerde antwoord hielp mij niet in mijn geval (Ubuntu 13.10), maar ik kon het bijwerken van het probleem omzeilen via de opdrachtregel in plaats van via Software Updater (voor het geval iemand anders tegen dit probleem aanloopt).

sudo aptitude upgrade

presenteerde me het specifieke pakket dat afkomstig was van een niet-vertrouwde bron (Google's Music Manager) en vroeg of ik het wilde accepteren en upgraden.


5
2018-03-15 11:01





Ik had precies dezelfde fout bij het bijwerken van de systeemindicator.

In mijn geval was dit vanwege ontbrekende GPG-sleutels. Er is een antwoord hier dat u zal instrueren om een ​​PPA manager te installeren en het kan proberen om alle ontbrekende sleutels te importeren. Ik deed dit en het gaf me geen bevestiging dat de ontbrekende sleutels waren geïmporteerd, maar ik heb de update achteraf uitgevoerd en het is prima geïnstalleerd.

Het is een vreselijk (niet-nuttig) foutbericht dat ik in dit geval moet zeggen.

https://askubuntu.com/a/386003/11929


2
2017-09-03 15:01



Dit was ook voor mij het probleem, daarna moest ik de oplossing volgen Jorge M. Treviño voordat ik met succes kon installeren - Heather Turner
Ik had een probleem met apt-fast, op de een of andere manier kon het het niet schoonmaken, dus dit werkte niet voor mij - serup