Vraag Hoe stel ik systeembrede proxyservers in Xubuntu, Lubuntu of Ubuntu Studio in?


Ik kan de proxy-instellingen nergens vinden. Moet ik het instellen via terminal, via gconftools of is daar een GUI voor aanwezig?


76
2018-06-13 06:52


oorsprong




antwoorden:


Systeembrede proxy's in Ubuntu Studio, Xubuntu en XFCE moeten worden ingesteld via omgevingsvariabelen

Ubuntu Studio gebruikt, net als Xubuntu, de XFCE-bureaubladomgeving die geen tool voor grafische instellingen bevat om systeembrede proxy's in te stellen (in tegenstelling tot de standaard Ubuntu-desktopomgeving, Unity).

1. Stel de proxy / proxies in voor de meeste programma's

  • Open de /etc/environment bestand met gksudo leafpad (of je favoriete editor). Dit bestand slaat de systeemomvattende variabelen op die tijdens het opstarten zijn geïnitialiseerd.
  • Voeg de volgende regels toe en wijzig deze op de juiste manier. U moet zowel hoofdletters als kleine letters dupliceren omdat (helaas) sommige programma's alleen op de ene of de andere manier zoeken:

    http_proxy = http: //myproxy.server.com: 8080 /
    https_proxy = http: //myproxy.server.com: 8080 /
    ftp_proxy = http: //myproxy.server.com: 8080 /
    no_proxy = "localhost, 127.0.0.1, localaddress, .localdomain.com"
    HTTP_PROXY = http: //myproxy.server.com: 8080 /
    HTTPS_PROXY = http: //myproxy.server.com: 8080 /
    FTP_PROXY = http: //myproxy.server.com: 8080 /
    No_proxy = "localhost, 127.0.0.1, localaddress, .localdomain.com"
    

2. Stel vervolgens proxies in voor GTK3-programma's zoals Rhythmbox:

Sommige nieuwere GTK3-programma's zoals Rhythmbox negeren de omgevingsvariabelen die hierboven zijn ingesteld en vertrouwen op Gnome-instellingen. Om ervoor te zorgen dat ze gedekt zijn, opent u een terminal en plakt u de onderstaande regel voor regel, en wijzigt u indien van toepassing:

gsettings set org.gnome.system.proxy mode 'manual' 
gsettings set org.gnome.system.proxy.http host 'myproxy.server.com'
gsettings set org.gnome.system.proxy.http port 8080

3. Stel ten slotte de proxies in voor apt-get en Update Manager

  • Deze programma's houden zich ook niet aan de omgevingsvariabelen. Maak een bestand met de naam 95proxies in /etc/apt/apt.conf.d/en neem het volgende op:

    Acquire :: http :: proxy "http://myproxy.server.com:8080/";
    Acquire :: ftp :: proxy "ftp://myproxy.server.com:8080/";
    Acquire :: https :: proxy "https://myproxy.server.com:8080/";
    

Log ten slotte uit en start opnieuw op om te zorgen dat de wijzigingen van kracht worden.


bronnen: 1, 2, 3. Zie 1 in het bijzonder voor aanvullende hulp, inclusief een script om de proxy's snel in of uit te schakelen.


Scripts om proxy-server aan / uit te zetten:

Disclaimer:: Alvorens verder te gaan, merk op dat ik dit heb geprobeerd op Lubuntu 14.04 en het is BELANGRIJK dat voordat je de genoemde scripts uitvoert, het bestand /etc/environment zou slechts één regel moeten bevatten, d.w.z. '$ PATH ...' en er zou niets anders in het bestand moeten staan, anders moet u misschien de scriptcode wijzigen. Deze scripts zetten de proxy in en uit, zoals hierboven beschreven, maar ze zijn afhankelijk van bestandstruncatie en bestandsbijlage die kan worden gewijzigd /etc/environment en /etc/apt/apt.conf.d/95proxies bestanden. Zorg er dus voor dat:

1) /etc/environment bevat slechts één regel, d.w.z. '$ PATH: ...'. En niets anders.

2) Het bestand /etc/apt/apt.conf.d/95proxies bestaat niet of heeft niets belangrijk daarin.

Zo! Als u het proces van het aan- en uitschakelen van proxy wilt automatiseren zonder dat u allot hoeft te typen. je kunt twee uitvoerbare shellscripts maken proxyon.sh en proxyoff.shals:

proxyon.sh:

if [ $(id -u) -ne 0 ]; then
  echo "This script must be run as root";
  exit 1;
fi

if [ $# -eq 2 ]
  then

  gsettings set org.gnome.system.proxy mode 'manual' ;
  gsettings set org.gnome.system.proxy.http host '$1';
  gsettings set org.gnome.system.proxy.http port $2;


  grep PATH /etc/environment > lol.t;
  printf \
  "http_proxy=http://$1:$2/\n\
  https_proxy=http://$1:$2/\n\
  ftp_proxy=http://$1:$2/\n\
  no_proxy=\"localhost,127.0.0.1,localaddress,.localdomain.com\"\n\
  HTTP_PROXY=http://$1:$2/\n\
  HTTPS_PROXY=http://$1:$2/\n\
  FTP_PROXY=http://$1:$2/\n\
  NO_PROXY=\"localhost,127.0.0.1,localaddress,.localdomain.com\"\n" >> lol.t;

  cat lol.t > /etc/environment;


  printf \
  "Acquire::http::proxy \"http://$1:$2/\";\n\
  Acquire::ftp::proxy \"ftp://$1:$2/\";\n\
  Acquire::https::proxy \"https://$1:$2/\";\n" > /etc/apt/apt.conf.d/95proxies;

  rm -rf lol.t;

  else

  printf "Usage $0 <proxy_ip> <proxy_port>\n";

fi

proxyoff.sh:

if [ $(id -u) -ne 0 ]; then
  echo "This script must be run as root";
  exit 1;
fi

gsettings set org.gnome.system.proxy mode 'none' ;

grep PATH /etc/environment > lol.t;
cat lol.t > /etc/environment;

printf "" > /etc/apt/apt.conf.d/95proxies;

rm -rf lol.t;

Hoe te gebruiken: Nadat u deze scripts hebt gemaakt, maakt u ze uitvoerbaar, u kunt ze waar u maar wilt houden. Om proxy aan te zetten, hoef je alleen maar naar de map met het script 'proxyon.sh' te gaan en dan moet je typen sudo ./proxyon.sh {host} {port}. Neem als voorbeeld dit:

 $ sudo ./proxyon.sh 10.2.20.17 8080
 OR
 $ sudo ./proxyon.sh myproxy.server.com 8080

Waar '10 .2.20.17 'het IP-adres van de proxy is, kunt u ook iets typen als myproxy.server.com - en' 8080 'is de poort. Meld u daarna af en log in op uw account om ervoor te zorgen dat alles is ingesteld. U kunt het internet gaan gebruiken of wat dan ook. En als u de proxy wilt uitschakelen, gaat u naar de map met 'proxyoff.sh' en typt u:

 $ sudo ./proxyoff.sh

Hiermee worden al uw proxy's uitgeschakeld. Log nu uit en log opnieuw in om over te schakelen naar de normale modus.


102
2018-06-15 01:18



Verwant: superuser.com/questions/357688/... - Grzegorz Oledzki
als je authenticatie nodig hebt voor apt-get proxy kun je ze als volgt instellen: Acquire :: http :: proxy "gebruiker: pass@myproxy.server.com: 8080 /";; - Jim Ford
alleen opnieuw opstarten en klaar voor xfce !. Bedankt. - RckLN
Het bovenstaande werkte voor mij. Maar wanneer ik mijn laptop mee naar huis neem, waar geen proxy is, kan ik geen verbinding maken met internet. Is er een snelkoppeling om de proxy opnieuw uit te schakelen als ik thuiskom zonder naar de extremen van roterende configuratiebestanden en opnieuw opstarten te gaan? Het zou een leuke toevoeging zijn op het antwoord. - TenLeftFingers
Voor beveiliging terwijl ik gebruik maak van openbare WiFi, probeer ik mijn Chromium-browser (in Xubuntu 16.04 LTS) te configureren om alle webpaginaverzoeken door te geven via een PuTTY Socks5-proxy op localhost: 10001, die thuis door een Raspberry Pi wordt getunneld terwijl ik weg van huis. De bovenstaande instructies werken niet voor Socks5-proxies, maar het lijkt erop dat ik het hopelijk kan achterhalen. (Opmerking: Firefox is gemakkelijk, omdat proxy-instellingen intern kunnen worden ingesteld binnen FireFox, maar ik wil ook de proxy instellen voor Chromium en apt-get, idealiter met DNS-verzoeken die ook via de proxy gaan). - Gabriel Staples


er is een grafische tool genaamd UbProxy, die de volledige systema-proxy instelt, via een grafische interface (GUI). Het enige probleem voor mij was dat ik mijn gebruiker uit moest loggen en opnieuw moest inloggen om de config te laden. Is heel eenvoudig te gebruiken. https://code.google.com/p/ubproxy/


8
2018-05-03 14:15



ziet er veelbelovend uit. - Dee
U kunt alle verschillende proxy-instellingen die voor verschillende toepassingen vereist zijn, automagisch configureren wanneer u verbinding maakt met WiFi of zelfs verbinding maakt met het bekabelde netwerk. Zien: gist.github.com/frgomes/544014b53e5384e00847da20b3e1da5b - Richard Gomes


Ik heb een aantal functies om daarmee om te gaan. Noem ze zo:

myProxyOn

https://gist.github.com/fernando-basso/6352040

#!/usr/bin/env bash

# gsettings list-recursively org.gnome.system.proxy

# Change de ip address and port number accordingly.
function myProxyOn() {
    gsettings set org.gnome.system.proxy mode 'manual' # ' manual / nome / automatic '
    gsettings set org.gnome.system.proxy.http host '10.0.0.1'
    gsettings set org.gnome.system.proxy.http port 8080
    gsettings set org.gnome.system.proxy.https host '10.0.0.1'
    gsettings set org.gnome.system.proxy.https port 8080
    gsettings set org.gnome.system.proxy.ftp host '10.0.0.1'
    gsettings set org.gnome.system.proxy.ftp port 8080

    echo "Configuração do 'System Proxy' settada para 'manual', com host 10.0.0.1, port 8080."
}

function myProxyOff() {
    gsettings set org.gnome.system.proxy mode 'none' # ' manual / nome / automatic '
    echo "Proxy cofigurado para 'none'."
}

function proxyOn() { # {{{
    #echo -n 'Username: '
    #read -e username
    #echo -n 'Password: '
    #read -es password
    #echo ''
    echo 'Setting variable "http_proxy"...'
    #export http_proxy="http://$username:$password@172.17.0.1:8080/"
    export http_proxy="http://10.0.0.1:8080/"
    echo 'Setting variable "https_proxy..."'
    export https_proxy="https://10.0.0.1:8080/"
    echo 'Setting variable "ftp_proxy"...'
    #export ftp_proxy="http://$username:$password@172.17.0.1:8080/"
    export ftp_proxy="ftp://10.0.0.1:8080/"
    echo 'Done!'
}

function proxyOff() {
    unset HTTP_PROXY
    unset http_proxy
    unset FTP_proxy
    unset ftp_proxy
    echo -e "\nProxy environment variables removed!"
}

3
2017-08-27 10:54



dat is een vreselijke suggestie om het wachtwoord in een tekstbestand op te slaan - BЈовић
@ BЈовић: Je hebt gelijk. In mijn geval is dit het openbare Uni Proxy-wachtwoord, dus ik denk dat het er niet toe doet. - Fernando Basso
enig idee hoe een socks proxy te configureren? - Gabriel Staples


Het is niet nodig om het hele systeem opnieuw op te starten voor apt-get tweak via proxy95-bestand in /etc/apt/apt.conf.d

  • Het werkt gewoon onmiddellijk nadat het bestand is geschreven en
  • het is verdwenen direct nadat het bestand verdwijnt.

Overweeg een script om het bestand in of uit te schakelen door het te hernoemen naar * .bak voor het snel wisselen van de proxy, indien nodig.


0
2018-03-14 10:04





Ga naar Dash Home type Systeeminstellingen, klik op systeeminstellingen en vervolgens op network.Proxy-instellingen zijn zichtbaar voor u. Klik systeembreed. Het kan werken zoals in systeem proxy-instellingen.


-3
2018-06-13 12:39



Studio gebruikt xfce niet ubuntu. - 23 93 26 35 19 57 3 89
Proberen superuser.com/questions/357688/... - 23 93 26 35 19 57 3 89