Vraag Is het mogelijk om GIMP 2.10.4 op Ubuntu 16.04 te laten werken? [duplicaat]


Deze vraag heeft hier al een antwoord:

Ik heb geprobeerd het te installeren vanaf de bron, maar er zijn een aantal afhankelijkheden, veel problemen en ik weet niet hoe ik ze moet krijgen - het lijkt alsof ze niet in repo zijn. Zou u GIMP 2.10.4 kunnen laten werken op uw Ubuntu 16.04? Hoe te installeren (en waar ze te krijgen) allemaal nodig voor afhankelijkheden?


1
2017-07-07 01:05


oorsprong


Gimp 2.10.0 is in een handomdraai verkrijgbaar. Het is mogelijk dat de glib / gtk + libs in 16.04 tool oud zijn voor Gimp 2.10.x, dus klikt waar ze zich bevinden binnen een mogelijk de gemakkelijkste. Een latere versie dan 2.10.0 is mogelijk beschikbaar; Ik heb niet gekeken - guiverc


antwoorden:


Het is mogelijk dat de glib / GTK + libs in 16.04 te oud zijn voor Gimp 2.10.x, dus klikt erop; waar bibliotheken (en andere afhankelijkheden) zich bevinden binnen [de module] zijn mogelijk de gemakkelijkste optie.

2.10.0 is beschikbaar in een handomdraai (https://snapcraft.io/gimp), die automatisch wordt bijgewerkt naar een latere module als / wanneer latere releases worden 'afgebroken'.

-

Joey Sneddon liet zien dat Gimp 2.10.4 beschikbaar is via Flathub

artikel: https://www.omgubuntu.co.uk/2018/07/gimp-2-10-4-released-with-faster-start-times-auto-straighten-tool

GIMP op Flathub: https://flathub.org/apps/details/org.gimp.GIMP

Ook uit het artikel van Joey Sneddon, de niet-officiële GIMP AppImage of de GIMP PPA van Otto Kesselgulasch kan later versies worden geleverd (2.10.3 & 2.10.2)

2.10.3 Niet-officiële GIMP-appImage https://github.com/aferrero2707/gimp-appimage

2.10.2 GIMP PPA van Otto Kesselggulasch: https://launchpad.net/~otto-kesselgulasch/+archive/ubuntu/gimp


4
2017-07-07 01:58





Gebruik Snappy

Meestal zijn de nieuwste versies van de apps zoals Gimp niet in de oudere maar nog steeds ondersteunde versies van Ubuntu zoals 16.04 LTS. Dit kan te wijten zijn aan afhankelijkheid of andere potentiële problemen.

Canonical's oplossing voor dit probleem is Snappy pakketbeheerder. Het Snappy-subsysteem is ingebouwd in de nieuwere versies van Ubuntu. Snap-pakketten kunnen worden geïnstalleerd via GUI of via de opdrachtregel.

Installeer door GUI

Open Ubuntu-software en zoek naar gimp:

enter image description here

Klik nu op de beschrijving van Gimp om deze uit te vouwen en scroll naar beneden.

enter image description here

Let op, het gimpversienummer en de ontwikkelaar. Als u tevreden bent, klikt u op Installeren en geef het wachtwoord op wanneer hierom wordt gevraagd.

Eén ding gaat over snap-pakketten is dat ze vrij groot zijn. Dit komt omdat ze op zichzelf staan ​​en alle afhankelijkheden in het pakket hebben opgeslagen. Elke snelle app wordt uitgevoerd in zijn eigen sandbox.

Snap-apps worden automatisch bijgewerkt naar de nieuwste versie zodra de ontwikkelde versie het bijgewerkte snap-pakket beschikbaar maakt. Dus, zelfs als er nu Gimp 10.0.0 staat, wordt het bijgewerkt als de nieuwste versie beschikbaar wordt in dit formaat.

Installeren op opdrachtregel

Om een ​​software in de snelle opslagplaatsen te zoeken, opent u een terminal door op te drukken Ctrl+alt+T en voer in:

snap find gimp

Je ziet zoiets als:

Name  Version  Developer     Notes  Summary
gimp  2.10.0   snapcrafters  -      GNU Image Manipulation Program

Gebruik de volgende opdracht om gimp te installeren:

sudo snap install gimp

Voer uw wachtwoord in wanneer daarom wordt gevraagd. In tegenstelling tot de GUI, zal de cursor niet bewegen en zal er geen zijn *s terwijl je typt. Dit is normaal in de wachtwoordprompt van de Ubuntu-opdrachtregel.

Zie ook dit OMG Ubuntu-verhaal van een paar maanden geleden voor andere manieren om Gimp te installeren.

Ik hoop dat dit helpt


3
2017-07-07 02:33



Bedankt, dat is handig, maar op dit moment blijkt snap 2.10.0 terwijl flatpak 2.10.4 biedt - net als de homepage van GIMP. - R S
Alstublieft. flatpack is een alternatief voor snap. Zoals PPA-repository's, snap pakketten worden vaker bijgewerkt en de gimp  snap wordt binnenkort bijgewerkt. Als u 2.10 nu in Snap installeert, krijgt u automatisch 2.10.4 wanneer deze beschikbaar is in snap. - user68186