Vraag Google-Chrome-stable blijft vragen of het moet worden ingesteld op de standaard


Sinds de Ubuntu 15.10-upgrade blijft Google-Chrome-stable vragen of het als standaardbrowser moet worden ingesteld, ook al is het dat al. Ik heb geprobeerd het opnieuw te installeren, maar dat hielp niet. Om het even welke ideeën?


77
2017-10-23 08:07


oorsprong


ga naar, ga naar algemene instellingen -> haal het vinkje weg Always check if chrome is your default browser - Ravan
Maar het moet niet melden dat het niet de standaardbrowser is, terwijl deze al is. Ik vermoed een fout hier. (Ik heb het ook gemerkt. Vanmorgen opgewaardeerd dus kan het nu niet onderzoeken.) - Jos
Ja, dat is het punt. Er staat dat het niet de standaardbrowser in de instellingen is en als ik op "Instellen op standaardbrowser" klik, verandert er niets. - Yanick Nedderhoff
Allereerst is dit forum niet voor bugrapporten, zoals vermeld in FAQ. Hier is informatie hoe bugs te melden. En hier is een tijdelijke oplossing voor uw probleem: - Yurii Kolesnykov
@YanickNedderhoff Ik heb bewerkingen voorgesteld voor de genoemde anwser. Maar voordat ze herzien, vervangt u 'Profiel 1' door pad in 'Standaard'. - Yurii Kolesnykov


antwoorden:


Zie het einde van dit antwoord voor de werkende oplossing.

EERSTE ANTWOORD 28 oktober 2015 (verouderde oplossing)

Om te voorkomen dat u wordt gevraagd of u Chrome als standaardbrowser wilt gebruiken, gebruikt u de volgende tijdelijke oplossing (voorgesteld hier en voorgesteld in het commentaargedeelte van deze vraag door Yurii Kolesnykov):

Open het bestand ~/.config/google-chrome/Default/Preferences met een teksteditor.

Zoek de lijn

"check_default_browser": true,

en vervang het door

"check_default_browser": false,

In mijn geval was het bestand> 200k tekens, waardoor gedit een paar keer crashte. Als het in uw geval hetzelfde is, wilt u waarschijnlijk een op een terminal gebaseerde editor zoals vi gebruiken.

Let op: dit is een oplossing, het probleem zelf moet worden verholpen door de Chrome-ontwikkelaars.

UPDATE 24 november 2015

Als Danilo Piazzalunga vermeld, de bug is bevestigd. Als NicDumZ gesuggereerd, stem deze bug alstublieft in door op te klikken

Does this Bug affect you?

om de aandacht te vestigen. Bedankt!

UPDATE 20 februari 2016

Zoals eerder gerapporteerd door Ron Thompson en 3vi1 in de commentaarsectie; en uiteindelijk bevestigd door mijzelf (met behulp van Ubuntu 15.10), lijkt deze oplossing niet meer te werken, tenminste niet voor iedereen, na het opnieuw installeren van Google Chrome. Iedereen die deze oplossing heeft gebruikt, moet proberen Chrome niet opnieuw te installeren.

Ik raad je nogmaals aan om te zeggen dat je last hebt van de bug lanceerplatform (momenteel 302 mensen).

UPDATE 5 april 2016 (werkende oplossing!)

EEN repareren is voorgesteld op lanceerplatform die blijkbaar het werk deed voor een paar mensen:

Als u de correctie wilt toepassen, wijzigt u regel # 198 in het bestand /usr/bin/xdg-settings van

command="`grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | sed -e 's/ .*$//'`"

naar

command="`grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | sed -e 's/ .*$//' | head -n 1`"

UPDATE 25 juli 2016 (werkende oplossing!)

Update naar de voorgestelde oplossing voor (K) Ubuntu 16.04:

Als u de fix wilt toepassen, wijzigt u de regels # 177 en # 202 in het bestand /usr/bin/xdg-settings van

command="`grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | first_word"

naar

command="`grep -E "^Exec(\[[^]=]*])?=" "$file" | cut -d= -f 2- | first_word | hoofd - n 1`"

Ga vervolgens naar de instellingen van Google Chrome en stel Chrome in als standaardbrowser.

UPDATE 1 juni 2017

De kever is vanaf vandaag gesloten en gemarkeerd als "Fix Released". De gebruiker citeren Olivier Tilloy (osomon):

Als ik het rapport goed lees, was het probleem opgelost in xdg-utils in xenial. Wily is al bijna een jaar EOL, dus ik sluit de bug.

no longer affects: chromium-browser no longer affects: google-chrome-beta (Ubuntu) no longer affects: google-chrome (Ubuntu) Changed in chromium-browser (Ubuntu): assignee: Chad Miller (cmiller) → nobody status: In Progress → Invalid Changed in xdg-utils (Ubuntu): assignee: Chad Miller (cmiller) → nobody status: Confirmed → Fix Released


54
2017-10-28 11:48



Zou je kunnen voorstellen het volgende te volgen? keveren stem het in door op te klikken "Heeft deze bug invloed op u?" ? Bedankt! - Nicolas Dumazet
Het lijkt erop dat het bugrapport voor Chromium is, maar deze fout is ook van toepassing op Google Chrome. Maakt dat uit? Ook verschijnt de regel "check_default_browser" niet in dat configuratiebestand voor mij. - Portugalthephilosoph
Ja, het heeft invloed op zowel Chromium als Chrome. Maar Chrome is gebaseerd op Chromium, dus als het is opgelost, moet het voor beide worden opgelost. Over die ontbrekende lijn: ik weet het niet. Mag gewoon de regel toevoegen en kijken of het werkt? - Yanick Nedderhoff
Gewoon om te bevestigen ... de nieuwe aangeboden oplossing (ter vervanging van de opdracht regex) werkt voor mij om 15.10 :) Bedankt. - TacB0sS
UPDATE 5 april 2016 (Working fix!) Heeft dit probleem voor mij opgelost, op Ubuntu 15.10 met Chrome versie 50.0.2661.102 (64-bit) - CharlyDelta


Dit is opgespoord als een fout in XDG-hulpprogramma's en heeft ook invloed op Chromium Browser.

Zien LP Bug # 1509139.


3
2017-11-11 22:01



Wat dacht je van een suggestie om het te stemmen door op te klikken "Heeft deze bug invloed op u?" ? Bedankt! - Nicolas Dumazet


Ik had hetzelfde probleem met 15.10. Elke keer dat ik opnieuw startte en begon met chrome, klaagde ik dat dit niet de standaardbrowser was, hoewel de details van de instellingen Default Applications de standaardinstelling voor internet is. Ik merkte dat firefox standaard was voor foto's, dus stel dat in op viewer. Nadat in totaal één keer opnieuw is opgestart, is chrome niet langer aan het klagen. Ik zou het nog een paar keer moeten proberen voordat ik beweer dat dit mijn probleem heeft opgelost, maar ik wilde het eerste resultaat delen als iemand in de modus is om zelf dingen te proberen.


-1
2017-12-31 17:22



Update: Misschien een rode haring. chrome: // instellingen laten nog steeds zien dat Chrome niet mijn standaardbrowser is. Ik moet tijdens het testen per ongeluk de knop "Niet vragen" hebben geraakt. Ik kan het bestand met voorkeuren niet vinden om die beslissing ongedaan te maken - mrh53