Vraag Draadloos netwerk werkt niet na hervatten in Ubuntu 14.04


[Bijwerken]:
Hetzelfde probleem doet zich voor in Kubuntu en wordt op dezelfde manier opgelost.
[Opgelost]:
Door het volgende commando toe te passen nmcli nm Ik heb het volgende:

Voordat u stopt

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         connected       enabled         enabled    enabled         enabled  

zoals je kunt zien dat de staat verbonden is en de rest ingeschakeld en actief is

Na het opschorten

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         asleep          enabled         enabled    enabled         disabled

zoals je kunt zien dat de staat slaapt, wat betekent dat onze dierbare netwerkbeheerder nog steeds slaapt, dus om op te lossen, gebruik de volgende opdrachtregel:
sudo nmcli nm sleep false
dit vertelt de netwerkbeheerder dat hij wakker moet worden. om dit permenant te maken:
maak een script aan in /etc/pm/sleep.d bevat het volgende (en vergeet niet om het script als uitvoerbaar te markeren):

#!/bin/sh

case "${1}" in
        resume|thaw)
        nmcli nm sleep false
                ;;
esac

Dankzij deze

Het oorspronkelijke probleem:

Ik heb zojuist Ubuntu 14.04 gedownload en op mijn laptop geïnstalleerd: ASUS X61SL met Intel P8400 Core2Duo x64-processor.
Wanneer ik het deksel sluit, wordt het systeem opgeschort, maar wanneer ik het deksel weer open en weer hervat, is het draadloze netwerk niet geactiveerd (netwerk als geheel is uitgeschakeld) en wanneer ik "Netwerk inschakelen" selecteert, gebeurt er niets.
Dit is de informatie over mijn draadloze adapter:

$ lspci | grep -i wireless
02:00.0 Network controller: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) (rev 01)  

Dit probleem was niet aanwezig in Ubuntu 13.04, Linux Mint Debian Edition of Debian 7 wheezy (GNOME of KDE).

Bewerken: een paar testen met de volgende resultaten:
Het probleem heeft gevolgen voor mijn draadloze en bekabelde netwerken.
Opmerking: ik moet het toevoegen pci=nomsi regel om te rooien om te booten.
Wanneer je handmatig uitlogt, stop dan en ga dan verder en log in alles werkt prima.
Wanneer u direct opschort terwijl u bent aangemeld, gebeurt het probleem.
Vergrendelen en opschorten veroorzaakt hetzelfde probleem als rechtstreeks opschorten.
Ook dit probleem lijkt niet van invloed op de uitlogfunctie: als u uitlogt in het gebruikersmenu in het eenheidspaneel, dan zou u niet uitloggen, maar als u de opdrachtregel gebruikt gnome-session-quit --logout dan kun je uitloggen.
Nu met lshw -C network output:
Normaal (volledig functioneel netwerken):

  *-network               
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: pci@0000:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A ip=6.6.6.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

Na het hervatten ("/etc/pm/config.d" bevat niet "unload_modules"):

 *-network DISABLED      
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: pci@0000:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network DISABLED
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

Toen ik het bestand unload_modules aan de map "/etc/pm/config.d" toevoegde zoals voorgesteld door hier, na het afmelden, onderbreken, hervatten en aanmelden bij de netwerkwerkzaamheden, maar ik kan geen verbinding maken met mijn draadloze netwerk.
Nogmaals het resultaat van lshw -C network Na het hervatten ("/etc/pm/config.d" bevat "unload_modules"):

 *-network DISABLED      
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: pci@0000:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network DISABLED
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

De inhoud van 'unload_modules' waarbij:

SUSPEND_MODULES="$SUSPEND_MODULES ath9k"
SUSPEND_MODULES="$SUSPEND_MODULES sis190"

Waar 'ath9k' mijn draadloze module is en 'sis190' mijn Ethernet-module.


78
2018-04-22 13:13


oorsprong


Ik heb de verbinding verbroken in plaats van in slaap te vallen in mijn status, hoe kan ik het probleem daarmee oplossen? Dankje - Luigi Tiburzi
Als je je eigen probleem oplost, zou je een antwoord moeten plaatsen, niet het antwoord in je vraag opnemen. - Duncan Jones
Nog steeds geen officiële oplossing voor dit probleem? Vanaf het lezen van de bug report Nee. Maar dit is hoogst verrassend omdat het nogal veel mensen treft ... - Augustin Riedinger
Het bevel nmcli nm klaagt: Object 'nm' is unknown - Alireza
Probeer @umpirsky nmcli general status - rsht


antwoorden:


De bovenstaande antwoorden werkten voor mij niet op 14.10. Na een beetje trial-and-error, ben ik hiermee beland,

#!/bin/sh

case "${1}" in
  resume|thaw)
    nmcli r wifi off && nmcli r wifi on ;;
esac

Zet dit erin /etc/pm/sleep.d/10_resume_wifi
Maak het uitvoerbaar sudo chmod 755 /etc/pm/sleep.d/10_resume_wifi en het probleem zou onmiddellijk moeten worden opgelost.


27
2018-04-13 20:03



dit loste het voor mij op 15.04 op - STW
Waarom niet "uit" voordat je gaat slapen? - Petr Gladkikh
Waar is de 'r' voor? Ik krijg "Fout: Object 'r' is onbekend." Dit lijkt voor mij te werken: "nmcli nm wifi on;" (ubuntu 14.04 - Dell Precision-laptop) - FizxMike
Werkte voor mij 16.04 - timkofu
@FizxMike The r specificeert object 'radio' in mijn versie van nmcli (Ubuntu 16.04). Wanneer ik typ nmcli r --help, Ik zie dat de beschikbare doelen van een commando zijn COMMAND := { all | wifi | wwan } en de beschikbare commando's zijn [ on | off]. Ik veronderstel dat het voorafgaand aan Ubuntu 14.10 niet mogelijk was om individuele objecten te targeten die worden bestuurd door NetworkManager. - MDMower


Ik heb een oplossing, maar dit is alleen voor het opnieuw opstarten van uw netwerkbeheerder.

sudo service network-manager restart

Het is niet de permanente oplossing.


21
2018-03-20 10:40



Deze oplossing is de enige die voor mij werkte op 15.10 met Intel Wireless 7260 - Anton Matosov
Deze oplossing is ook bewerkt op 14.04 LTS en 14.10 - hmjha
Werkte. @hmjha Misschien kunnen we er een script in schrijven /etc/pm/sleep.d die controleert of wifi werkt en opnieuw start network-manager als niet? - umpirsky
@umpirsky ja, we kunnen ook van die methode doen. Bedankt - hmjha
Werkte voor mij op Ubuntu 16.10. Blijkbaar wordt /etc/pm/sleep.d niet langer gebruikt. Ik plaats het in plaats daarvan in / lib / systemd / system-sleep, als: #! / Bin / sh case $ 1 in post) service network-manager restart ;; esac - Marc Rochkind


Het script dat uiteindelijk voor mij werkte:

$ cat /etc/pm/sleep.d/10_resume_wifi 
#!/bin/sh

case "${1}" in
  resume|thaw) nmcli nm sleep false ;;
esac

$ ll /etc/pm/sleep.d/10_resume_wifi
-rwxr-xr-x 1 root root 70 mars  31 09:09 /etc/pm/sleep.d/10_resume_wifi

Het andere antwoord heeft typefouten (ze kunnen worden opgelost weet ik), maar ze hebben toch nooit voor me gewerkt.


4
2018-03-31 07:21



Kan ik dit op de een of andere manier testen zonder het permanent te maken? Wat doen de commando's? - tokam
Tokam, zie mijn opmerking hierboven op Owais 'bericht over "nmcli nm wifi on" dat eerst in het script werkte. Kortom, door een script in de slaap.d-map te plaatsen, wordt het op de hervattingstijd uitgevoerd en krijgt het 'hervatten' of 'ontdooien'. Het script controleert of argumenten worden doorgegeven aan het script en voert de opdracht nmcli uit (Network Manager Command Line Interface). De specifieke opdracht die ik heb genoemd, komt overeen met het klikken op netwerkbeheerder in de statusbalk en het aanvinken van "WiFi inschakelen". Voer voor verificatie "nmcli nm help" in terminal in. Ook moet je ervoor zorgen dat het script uitvoerbaar is. - FizxMike
Dit werkt voor mij op mint mate 18, die gebaseerd is op ubuntu 16.04.1. - Eric Wang


Dit werkte voor mij op Ubuntu 14.04 op een Dell Precision-laptop.

Voer in een terminal in:

sudo nano /etc/pm/sleep.d/10_resume_wifi

Plak dan in (ctrl + v):

#!/bin/sh
case "${1}" in
resume|thaw)
    nmcli nm wifi on
    ;;
esac

Maak het script vervolgens uitvoerbaar:

sudo chmod +x /etc/pm/sleep.d/10_resume_wifi

Test de Suspend en wake om wifi te zien !!


0
2018-05-15 00:05





Heb je geprobeerd om een ​​ander script zoals dit in kate in te voeren:

#/bin/sh

    case ![1] in
        ./bin/sh
        network="true"
        nmcli nm -c sleep=false -network
    endasc

en sla het op als jsin7 bestand in / etc / network, en noem het network.d en dit werkt misschien goed.


-3
2018-05-30 09:45



Ik denk dat de syntaxis onlangs is veranderd, ik word uitgewezen nmcli nm sleep false gevolgd door nm wifi on om het te laten draaien. +1 voor de tip! - Mahmoud Al-Qudsi
Het bevel sudo nmcli nm sleep false werkt voor mij, dus ik zit niet vast. Maar de /etc/network/network.d script wordt niet automatisch hervat. Als ik het probeer uit te voeren, krijg ik het Syntax error: newline unexpected (expecting ")"). Zou je specifieker kunnen zijn over de 1. Waarom het niet werkt? 2. Wat wordt verondersteld het script te doen (zodat we het individueel kunnen oplossen)? 3. Waarom network.d? Bedankt! - Augustin Riedinger
Wat moet dit doen? Wat is ![$]? Waarom ./bin/sh? Je bent in /etc/network, er zal geen .... zijn ./bin/sh er. Wat is een jsin7 het dossier? Case statements eindigen met esac, niet easc. Ze hebben ook een variabele en een voorwaarde nodig. - terdon♦